Issue with running DGP component in Sample File

Hello all,
I tried to run a PIT view based analysis using the sample file. I have updated to the latest development version too. But the dgp component fails to run throwing error as follows : (82.9 KB)
Before updating to the latest development version it was working fine.

Hi @Asisnath,

I am not able to recreate the issue. Can you share the HDR image? Can you check if the error happens in line 155 in the component?

Sorry for late reply @mikkel . This is the simulated output folder with hdr images. I tried to install in other system too to check if its error on mys ystem but it failed in my other system too.

Hi @Asisnath,

It is the resolution string on line 155 as I expected. You are using a newer version of Radiance than the one from the compatibility matrix.

Here is the resolution string of your HDR:

In previous Radiance versions it is formatted like this:

Seems like it changed in this Radiance version. Since we are eventually going to bump the compatible Radiance version to a newer version at some point, I pushed a PR of the “HB Glare Postprocess” component that works with both resolution string formats. If @chris approves it should fix your problem now, but more importantly also avoid future problems when the compatibility matrix changes.

1 Like

Thanks for the info @mikkel . I installed LBT from the latest Rhino pollination installer (0.150.2). I didnt knew that it is using now the upgraded version of radiance.

Hi @Asisnath,

You are right that the installer uses a newer version (didn’t know that either). However, after conversing with Chris, you should not worry about that, since there are usually not breaking changes between Radiance releases. Any compatibility issues will instead be fixed as they appear.

The fix should be available with LB Versioner now.


Hi @mikkel I’ve the same problem as mentioned at the beginning, I have already read the comments but I don’t understand how I could solve it without switching to 1.5 version. I recently downloaded the latest Radiance version, so I don’t understand what could be wrong. While, I understand that I have to resize the image I don’t know from what point it is changed.
I hope you can help me and stay tuned.
As always, thank you so much and best regards.


1 Like

You have to update the components on your canvas to use the LBT 1.5 version. The quick/automated way to do this is with the LB Sync Grasshopper File component.

I did it with LBT 1.5 and it works, thank you so much @chris

1 Like