LadyBug sun analysis diagram shows only blue

Hello all,
I am trying to make a solar analysis with ladybug, but i get only blue, as if there is no sun at all,
what am i doing wrong?
any help will be much appreciated.

i really do not get it, its as if there is no sun

Hi Ali,

It looks like there’s an issue with how meshes are being previewed in your view properties. How does it look in wireframe or shaded?

Also try deleting the preview component in grasshopper, that can interfere with other previews even when it’s preview is turned off.

I also wouldn’t mesh your breps before sending them to the sun hours analysis, best to let the sun hours analysis component do the meshing for your based on the grid size you input.

Hope that helps,

1 Like

Hi Charlie, thank you very much for taking the time and looking at my issue,
i uninstalled and reinstalled LB, and it a bit better, but yet graphically its pretty mellow,
any idea why?

Hi Ali,

Did you try any other view settings? Looking on my phone the screenshots you’re sharing look close to black on the building geometry and the legend.


Did you try to flip the normal direction of the geometry? It is probably pointing inside?

Yes, that’s my problem, it is as if there is no sun.
i don’t get it ,
Sadly i can’t upload my file…

nothing works
i am sure there is something wrong with my input data, but i can’t understand what,
i even trid to draw another geometry, to see if thats the problem, it did not works either.

Hi Ali,

This is what I mean by changing the view settings:


tried, nothing better.
it just becomes completely black - both legend and analysis output.
tired to run it on another PC, got the same result…

Hi Ali,

Very strange! Might be one for the Rhino discourse as your script looks fine which makes me think it’s a rhino rendering problem.

I just googled the problem and spotted this thread which might help Black geometry in GH - #35 by SaeranVasanthakumar

For comparison here’s an example of a bunch of different view properties on my laptop






Hey Charlie,
Thank you very much for keep on trying to help me.
i will try the link you kindly proposed, and if it wouldn’t work will go back to grasshopper forum, which sent me here on the first place.

I think Charlie is on to the right explanation here. We should ask: what version of Rhino are you using (including the minor version or service release)?

We know that the plugin works well in the latest versions of Rhino 6 and Rhino 7 but we make no promises about other versions (especially if it’s the Rhino 8 beta).