Terrain Generator Release



That’s a very useful feature Antonello!!
Keep up the great work!


Hello Antonello and Djordje,

First thank you very much for your two super useful components!

I used to have the same workflow as Djordje’s component using opentopography data but written with “ugly” “basic” Grasshopper and PythonGh script. So I am super happy to have this new TerrainGenerator2 component added to Ladybug suite ! :slight_smile:

However, following the install instructions and checking for the opentopography.org availability, the component does not seem to manage to download the data… (see picture attached).
Djordje, do you have any idea about what I can I do or check to fix this?

Other question, just to be sure, regarding the “origin_”, is it the central point that you to get out of the output mesh/surface? And does it need to be the point at the actual point elevation or does it need to be the point projected on the ground floor (as I do in my definition)?

Thanks again for your work,



Hi Aymeric,

Thank you for the kind words.

I opened a new topic in here, to answer your questions.

Best regards to lovely Réunion.


Firstly many thanks for this extremely useful component.

I tried to run the script on my work pc, it shows an error. It works on my personal laptop though. Any suggestions/comments what I can change to make it work.


Hi Saket,

There’s an update to the component you’re using. Can you please update the same? The update date is Jan 12 2017. I hit this error once and re-running the solver solved it.



Hi Devang,

Gives the same error unfortunately.

Terrain generator

Can you share the file?


Although didn’t make any changes in the example file but still, if you want to have a look.

On a side note it works on my personal laptop.

example_LB_terrain_generator.gh (371 KB)


example_LB_terrain_generator.gh (371 KB)


Same error. So it has something to do with how the internet security they have at my workplace deals with the way component collects data.I changed a boolean in the py which generates the error statement. It generates this error then -



Judging from the error message and the fact that it is working on your personal laptop but not a work laptop, I would guess that the error has something to do with a company firewall or antivirus software. If you could find a way to disable this or add an exception, my guess is that it should work.



Thanks for the input Chris,

I will get in touch with IT and see what they can do about it.

btw add an exception to …? Rhino?


This might not be the case with you Saket but using a faster internet connection can also make “Please enable internet connection” go away. Posting this for other people who might face this error.