UWG: modified epw missing or not generated

Hey guys, I’m quite new here and I apologize in advance if my issues with the UWG are too elementary (or have been solved quite a while ago) and I have not been lead to that page or post.

I am trying to modify an .epw to account for UHI. I have a simple Rhino model and I have seemingly satisfied the necessary prerequisites to run the UWG in GH. However, the UWG doesn’t seem to be outputting a newly modified .epw. It does provide a path for the supposedly ‘newly modified .epw’ but nothing is there. I am guessing the model isn’t running.

What might be a potential issue here? I tried to upload the 3d model and the gh file but “new users cannot upload attachments.”

@bryonflowers I could be wrong, but you might be using an older version of Dragonfly. It looks like your epw import is from 1.2.x but dragonfly in is older.

Try to close Rhino/GH and delete C:\Users\USERNAME\AppData\Roaming\Grasshopper\Libraries\ladybug_grasshopper_dotnet then open and run 'LB Versioner" with no input for “version_”. Then, close and re-open Rhino/GH

Yep, you are using Dragonfly Legacy in that screenshot.

There’s full support for UWG modeling in LBT Dragonfly 1.2.0.

1 Like

Hello to you both @chris @jgbrear,

I really appreciate your response. The work that is being put into this product (LB) must be substantial and I want to thank you for making it available.

I made the necessary adjustments removing the legacy model and creating a LBT Dragonfly 1.2.0 model. Everything seems in order but when I run the UWG I get the following error:

Any thoughts as to why it is generating a “DivideByZeroException”?

Thank you in advance,

Thanks, @bryonflowers . It’s possible that your model has zero floor area or something like that, which is causing the error. If you upload a sample file that recreates the issue, I’ll investigate and I’ll either push a fix or tell you what you need to change to your model to get it to simulate.

Hey Chris,

Many thanks. I compressed the gh.file and the rhino model in the following link:


I would have uploaded them directly here but the allowable “maximum size is 1500kb.”

Many thanks @chris.

Thanks @bryonflowers ,

The ZeroDivisionError was happening because your dragonfly buildings have no windows and I hadn’t encountered this case yet. You may want to add some WindowParameters to your dragonfly buildings if you want the heat exchange between the windows and the street canyons to be accounted for in the UWG simulation. In any event, I pushed a fix so that the simulation still runs for your case of no windows and you can get the fix on your end with the “LB Versioner” component in an hour or so.

Also, your trees are way more detailed than they need to be. For the new LBT dragonfly plugin, you should model the trees as 2D surfaces (representing the canopy in plan view) instead of volumes. And there’s definitely no need to model tree trunks for geometry like this. In fact, unless you are running an energy or daylight simulation with this dragonfly model, it’s probably easier to account for the trees using the tree_cover_ input instead of tree geometry.


1 Like

Thank you very much @chris ,

I’ll implement the changes. Both the 2d trees and the windows. I will inform you of the results. I also want to thank you for developing an additional fix for this.

Thank you,

Hey @chris ,

UWG simulation a success. Both solutions you provided work: the windowless simulation bug fix and including windows into the model.

Awesome work! Thank you very much!