Warmup Convergence Error

1. The simulation has not run correctly because of this severe error: **
** ** Severe ** CheckWarmupConvergence: Loads Initialization, Zone=“E1” did not converge after 25 warmup days.

Hello,

I am trying to simulate a courtyard typology with 32 zones involves. As soon as I try to connect the natural ventilation component, it starts producing the above mentioned error. Please find enclosed images . I hope you could help.

Thanks.

Regards,

Sakshay

Can you please share a simplified version of your GH file?

https://drive.google.com/drive/folders/1ug0_Nu9D9wORQTxHK81k6ceVIBQTjO7S?usp=sharing

Can you save as the rhino file in version 5 please?

Replaced the file.
https://drive.google.com/drive/folders/1ug0_Nu9D9wORQTxHK81k6ceVIBQTjO7S?usp=sharing

I took a look at the file. It’s a complex file and needs simplification before someone can take a look. Kindly go through these guidelines and re-share a simplified version of the file please.

Hi Devang,

I went through the guidelines and simplified the file into 5 parts; geometry, profiles, internal loads, hvac/natvent and run simulation. I also internalized the geometry for ease and marked the boolean toggles to be made true. I hope it becomes understandable.

I also came across this other post from the forum, but didn’t seem to help the problem. (WarmupConvergence)

I also tried increasing the warmup days using simulation control, energy sim parameters components.
(image enclosed)

Please find the revised file in the following folder:
https://drive.google.com/drive/folders/1ug0_Nu9D9wORQTxHK81k6ceVIBQTjO7S?usp=sharing

Thank You

Regards
Sakshay

hi,have you found any solution because i am having the same problem for the first time,even though i ran the simulation before with no warnings

Hi,
does anyone know how to solve this?
Thanks

UPDATE:
I found this discussion, and it suggests to change Loads Convergence Tolerance Value .
Does anyone know how it can be done in honeybee?

I had the same “…did not converge after 25 warmup days.” error and solved it by increasing maxWarmupDays_ as shown in the screenshot below.

1 Like

I’m getting the same error in HB-Energy 1.2.0. It looks like the maxWarmupDays_ was removed from SimControls. How should I address this in 1.2.0?

Hey sleaman, I don’t know for certain but I feel whenever I get warm up error in 1.2 there’s something else wrong/not ideal in the script or geometry. Also try basic stuff like shutting everything down and reopening if the error came out of no where.
Hopefully someone who can answer your question specifically replies.

I’ll try to at least expose the warmup convergence limits on the SDK layer if not a LBT Grasshopper component. I opened an issue for it and I will close it when it gets addressed.

I hadn’t labeled it a high priority since increasing the warmup days usually didn’t result in convergence for a lot of my cases. But I know that’s just because many of my cases involved feedback loops between various building controls, especially natural ventilation controls. So just tweaking those controls often resulted in stable simulations.