What folders are acceptable for Radiance simulation?

Hi @chris . Though I am not using acclerade and updated to the latest dev version, the recipe now throws an error. Earlier it was working.

I am not able to recreate the issue @Asisnath , and it seems unrelated to the change I just made for Accelerad.

Are you sure that your installation version and the components on the canvas match?

I just plugged in a directory to save data and it works fine. But if i leave _folder option blank it is throwing error.

Does your user name have any non-ASCII or special characters in it? Also, do you have write access to your simulation folder? Things are fine on my end if I use an appropriate path:

I guess I should clarify: Do you have permission to write to C:\Users\chris\simulation\[MODEL_NAME]? Also, are you sure that you don’t have that folder open in Windows Explorer or anything else that would interfere with writing to it.

I checked the permission write it is fine on my system. I tried to delete the radiance check inside the component but the simulation window is not stopping it is continuing in a loop i guess.This example file should not take more than 50sec on my system as earlier i have tested

My default simulation folder path is C:\Users\asisi\simulation\sample_model_grid


I have the same problem, can you explain which lines should be deleted?


Thank you both and sorry for the late response. This is a weird one. Can you post screenshots of what the “HB Config” and “HB Check Versions” components looks like as you see on the Wiki:

In particular, it would be good to know what honeybee thinks the default_sim folder is here along with the radiance installation.

This post is sounding a bit like several unrelated issues and I don’t see a common thread yet. I guess, if we really think it’s the result of the recent change we made to accommodate Accelerad, you can do the following test:

  1. Open the following file in a text editor:
  2. Change the following two lines of code in the file to use rtracte instead of mkmap:
    fix(config): Grab Radiance version number from mkpmap · ladybug-tools/honeybee-radiance@8e3ada5 · GitHub
  3. Save it and restart Rhino/Grasshopper.

If that doesn’t fix it, then we know that it’s unrelated to the recent change.

Also, one other thing you could do to test if it’s the result of a recent change is use the “LB Versioner” to go back to the sable release 1.2.0. If going back to the stable release fixes it, then we know it’s the result of some change that we made in the last month or so.

@chris I did a complete fresh installation of windows earlier today (as I was planning from some weeks) and again reinstalled all the LBT tools from scratch with latest development update. Now its working without any error. I don’t know why was the error popping up earlier. @ehsan.anvary formatting my system worked for me to eliminate the radiance error.

Thanks for the guidance, I have this error on a computer at the office that not an admin account but has full access to the simulation folder. I have this error with LB 1.1 and 1.2. I should implement what @chris said and see the result.
@Asisnath unfortunately it’s not easy to reinstall the program there.
also, I should say that I work with honeybee 0.66 without any problem.

This sounds like it resulted from something outside of Ladybug Tools. Maybe a Windows security update or an update to some antivirus software? In any case, I think you will probably have to interface with your IT, @ehsan.anvary , and I think you might as well get them to reinstall everything like @Asisnath did. Note that there’s an uninstaller that you can use to wipe the slate clean, which I posted at the top of the last release notes:

1 Like