Why do I get this message: Failed to import X: No module named X

I’m still unable to use any of the Ladybug/Honeybee components and getting the “failed to import…” errors.

I have added the paths manually to the Python Search paths too.
Output when I run

import sys

C:\Program Files\Rhino 6\Plug-ins\IronPython\Lib
C:\Users\TSA94506\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\lib

I also meet this problem, how can I solve this, really thanks if there is anyone can help me!


I am getting the same error, I am using it on mac (OSX). I couldn’t find the python file (in users folder) which needs to run in step 4.

Thanks in advance.

There is no .bat file to run when you are on OSX. See the Mac installation instructions:

If you’re still having difficulty, try deleting the folder at:
Then, re-run the installer.gh

Just to add my 2 cents here for Mac installations.
Once you’ve followed all the instructions, make sure to right click Rhino and Quit before relaunching.
Simply closing a Rhino window on Mac won’t reload all the changes made by the instalations.
Maybe trivial, but I did go in circles for a while.

1 Like