1. Solution exception: File could not be found'C:\Users\JoseÁngel\AppData\Roaming\Ladybug\SANTIAGO_CHL\SANTIAGO_CHL_dif_1.mtx'.

Hello everyone. I just started using ladybug and as soon as I try to load any epw file into GenCumulativeSky I keep getting the error

“1. Solution exception:No se pudo encontrar el archivo ‘C:\Users\JoseÁngel\AppData\Roaming\Ladybug\SANTIAGO_CHL\SANTIAGO_CHL_dif_1.mtx’.”

which means something like

“1. Solution exception:File could not be found ‘C:\Users\JoseÁngel\AppData\Roaming\Ladybug\SANTIAGO_CHL\SANTIAGO_CHL_dif_1.mtx’.”

I had trouble installing GhPython but I think I solved it following what I found through the discussions but I couldn’t manage to find anything working for me.

Attached an image showing the issue.

Thanks in advance.

Hi Jose, Sorry that nobody get back to you sooner. This is because of a downloading issue that we are facing recently. Please follow the instruction below and it should be fixed. Let me know if you have any other questions. -Mostapha

If you are experiencing any issues with downloading gendaymtx, OpenStudio libraries and other Ladybug and Honeybee files, you can download all the files from this link as a .zip file and manually extract it to Ladybug folder: (https://app.box.com/s/bh9sbpgajdtmmystv3n4).

You can find ladybug default folder by checking the output of Ladybug_Ladybug component. It should be c:\ladybug or C:\Users%USERNAME%\AppData\Roaming\Ladybug depending on your user permissions.

Hi Mostapha: thanks for your interest.

At first I did get an error asking for the gendaymtx file which it could not find but I had already solved that downloading as you say the file from an older discussion.

The thing is now it is a .mtx file (depending from the .epw I think) which it cannot find now. I’m trying to make an evaluation for Santiago in Chile: I already downladed the Santiago.epw file but now it is asking (as you can see in the image I attached) for let’s say Santiago.mtx and that one I don’t know how to get.

Thanks a lot for your attention!

Hi Jose,

This is working for me. Maybe your EPW is corrupted?

I’m attaching a working file and a snapshot showing the location of the MTX file.

I’m using the last version from the github.


GenCumSky.gh (345 KB)

Hi guys. I finally got it to work!

The problem was as already explained that for some reason it couldn’t work with my default ladybug path. The thing is I hadn’t understood that it was possible to change the path to “C:/Ladybug” just by typing it in: I thought it either was the one or the other but not that I could change it somehow by myself!

Thanks a lot for your patience!