1. The simulation has not run correctly because of this severe error: ** Severe ** <root>[RunPeriod][Run Period 1][end_day_of_month] - Value type "string" for input "UseWeatherFile" not permitted by 'type' constraint

Hello there, I continue to get this error when running OpenStudio simulation. Some time ago when I reinstalled it seemed to had ben solved, but came back up.

Ever seen something like that before? I am pretty sure it has something to do with the OS version installed or the likes (all up to date I believe) as It comes up with any premade GH graph involving OpenStudio simulation which should normally work (and it normally did, until recently), but I cant really grab a hold of how to actually fix this.

Kind regards and thank you in advance for your time :smile:

Someone can take a look if you post your file. Do you have any special character in the file name of your weatherfile?

Thing is, there’s no particular file, it happens with several examples in the hydra repository involving OpenStudio simulation.

To put it in perspective, recently, when starting a new file in Grasshopper, Honeybee wouldn’t recognize Openstudio. I found out that When I changed the default installation folder from “openstudio-2.9.1” to simply “Openstudio” it did, so I changed it.

But then this happened: Openstudio would stop working when running simulations in those older repository files, and throws that error I mentioned

I managed to “fix” this issue by changing the name in the default folder back from “Openstudio” to “openstudio-2.9.1”

There’s something to be mentioned as well: I happen to have both openstudio-2.9.1 AND openstudio-2.9.0 currently installed. (no reasons, really).

It’s quite weird

Please try with OpenStudio 2.5 from this link

I have the exact same message. And have solved the issue.

It happens with the simple Energy Balance example file. And it was easy to fix (once I saw this post and it clued me into where to look at my problem): I needed to ensure that HB was finding the correct version of Open Studio, and I even needed to delete the residual directory that my Open Studio uninstall command had not removed from the C:\ drive of my Windows machine.

I had been fiddling about installing the beta versions of the next version of Open Studio ( the one where they break it into two constituent parts an engine and an interface as I understand it). Because I had done that Honeybee was loading this beta not the v2.9.1 I wanted it to load.
image
As noted, even after uninstalling it, I still got the message quoted:
[The simulation has not run correctly because of this severe error: ** Severe ** [RunPeriod][Run Period 1][end_day_of_month] - Value type “string” for input “UseWeatherFile” not permitted by ‘type’ constraint](https://discourse.ladybug.tools/t/1-the-simulation-has-not-run-correctly-because-of-this-severe-error-severe-root-runperiod-run-period-1-end-day-of-month-value-type-string-for-input-useweatherfile-

The clue that something was wrong comes as hb-legacy is loading - not in the Grasshopper window, but in the Rhino window:
image

That hb is looking in the wrong place for code can easily be determined by looking into the output of the HB bug fly process:

After uninstalling the Beta, and removing the residual directly in which it had been installed from the C:\ drive. things looked much better:

AND: the file ran seamlessly (even with my much altered geometry (I and a colleague are building a HUI driven version for our colleagues’ thermal environment classes, so seamless and modelling flexibility is important)

M

Hello @MichaelDonn and @LVD
I have a same problem with EnergyPlus.
If you solved your problem, would you have any suggestion to me?

EnergyPlus 9.6 is not compatible with Legacy Honeybee. You need to use the latest development version of the LBT plugin if you want to use E+ 9.6.

thanks for your reply,
But I installed LBT1.3 before, I work with EP 9.5 too.
actually I dont want to use LBT for now. I just used EP and wrote the numbers by myself again, the error didn’t solve.
Im not sure, maybe it is raleted to Martix!??!


I can not find what numbers should be here