5PM Runtime error and multiple execution


I’m getting a runtime error when using the 5-phase method (5PM) in Honeybee +. I’m using the same workflow as I used succesfully (without error) 3 months ago, with updated userObjects. Have also tried using the example file for 5PM (updating the userObjects), with the same error clear.xml (337.4 KB)
diffuse50.xml (268.6 KB)
11_five_phase_I_gridbased_updated.gh (497.6 KB)

The issue is that results can’t be loaded back into Grasshopper:

The 5PM simulations also seems to be running more than ones. The results files appear when first “round” is complete, but anyway does the simulation run again.


Hi @tobiaspedersentsp, if you can share a link of the files written by Honeybee[+] before the simulation is run, I can look into it. As per Mostapha, the dual run thing that you pointed out is intentional because the window groups are handled slightly different compared to standard workflow recommended by LBNL.


(PS: I will try to get back to you in a couple of days, but cant promise for sure.)

Thank you @sarith

Here is the files written by HB+ before run, from the example file: test_room.zip (782.8 KB)

Regarding multiple executions; yes I know what you mean if you are refering to 5PM HB+ implementation .

However that doesn’t seem to be what is going on:

-Look at this copy of the commandprompt from an execution of the 5PM 5PMcommandPrompt.txt (27.0 KB) (seems to me that it is repeating)

-Simulation times are way higher than usually.

On my Linux system, I am getting some errors related to empty files and buffer overflow with rcontrib. And I also see three separate calls to rcontrib for direct calculations (Five phase usually requires a single call).
I guess the script has been modified to let the users delineate the results as per single window groups and then try out different combinations to see the effect of individual contributions. There are several additions to the script that I had worked on last year. @mostapha would be the right person to answer the specifics.