A problem/Ladybug_Sunlight Hours Analysis

Hello everybody,

I’m a beginner on Ladybug. I have been practising Ladybug by watching all videos on Youtube. But there is a small problem showed up. When I was setting up point for textpoints, the points which were supposed to show up on the Rhino didn’t show up and I thought It’s probably because I didn’t link sunvetors but, after I linked sunvectors to Sunlight Hours Analysis, the programme stopped working. I don’t know how to solve this one. I’m currently using 0.0.62 ver and the lastest one of grasshopper. Thanks for reading :smiley:

it says floating parameter Pt failed to collect data.

Hi Misung,

First of all a couple of information about LB components: if you see the inputs, you’ll see some underscores on the right side, left side or both side of the words.
Left underscore: you need this to run the component
Right underscore: it is optional
On the both sides means: you need this but there is a default value inside, so if you don’t connect a data, the component uses the default value as input.

To run LB sunlight hours analysis you need _geometry, _disFromBase, _sunVectors, _runIt.

Coming back to your issue, Have you set a Brep in Grasshopper? When a component or a parameter becomes orange there is a warning for you.

I suggest you also take a look at example files on Hydrashare:




Hello Antonello,

Thanks very much indeed for your kind comments.

I have set a brep in Grasshopper and linked every needed info(Geometry,gridsize,disfrombase,toggle). However, the problem is when I set a point component to testPts, it doesn’t show up in Rhino model and when I changed Toggle False to True after linking every needed components even sunvectors, Programme stopped working and stuck.


Could you attach your *.gh file? So I can check it.




Thanks! I think It’s because I set up mesh not surfaces. Is it correct?

I’m not sure about it.

unnamed.gh (540 KB)


I don’t think so, Grasshopper doesn’t let you select a brep if it is a mesh.

It seems like you have deleted breps without internalizing them.

If you connect a brep/or breps your file works fine.




I really appreciate your examples! Then I maybe set up too many breps which was over 40 buildings. I have figured out that if I make small numbers of buildings, It works fine. :smiley: Thank you very much

Best regrards


I suggest to check the size of your grid. It is not about the number of breps.


Thanks very much! That was the main problem I think

Hello Advisors!!
I need help …
I have the exact same problem as above mentioned by @MisungKwon and I am also a new user.

I tried to check my testpoints and the points which were supposed to show up on the Rhino didn’t show up. After I linked sunvectors to Sunlight Hours Analysis, the programme stopped working.

All the dialogue boxes are in normal status (light grey) where I connected and set the grid size (1), geometry (brep), dis fr base (0.1) on the input side. I connected a “point” to “testpt” on the output to preview the test points but I cannot view. I linked a panel to view the test point and it states "0 ".

My rhino model is imported from sketchup file (in millimeters) and I have simplified the model and group them before assigning to brep in GH. I am not sure why I cannot view the testpoints and I cannot run it after I connect sunvectors.

I’m currently using Rhino 6 with latest version of GH, LB and HB. Sorry, I am new so forum doesn’t allow me to upload any files :frowning:

Any advice will be appreciated!!

Hello @Joey_L , as you have used mm as units the grid size you have mentioned is very small for analysis. I recommend to use meters as units ( or in mm but increase grid size like 500mm) and provide a reasonable grid size. And also recheck if all the surfaces for up orientations.

@Asisnath Thank you!! I managed to simulate after I changed my model to meters unit but i still cannot preview my test points… Is there something else I need to set?

How do I check the surfaces for up orientations? Thank you in advance!

@Joey_L if you could share your gh definition i could check and suggest changes if any.

Unfortunately, this forum does not allow me to upload file because I am a new member… Here is the link to download my GH file.

@Joey_L i checked your file. The geometries were missing. You had sun vectors missing for analysis. I have modified and reattached the file. 2020-04-29_Option 05_base model.gh (492.6 KB)

Oh thanks!
Yes, I did not link up the sunvectors as previously the file will crash once I connect it…

I am still not able to see the testpoint preview so here is the link to the rhino file.

it is working correctly. test points is visualised once you set the component to run.

ohhh… i thought i could preview it before i run it…
by the way… how do i check on the surface orientation? which command to use?

You can type Dir and click on the surfaces