AddSubface not working for some windows


I am trying to add a large amount of windows (2398) to a large amount of rooms (788) using the HB Add Subface component. For some reason, some windows are not added to some rooms. Surprisingly though, it works when treating these windows and rooms separately… how can that be?

I can’t share the model unfortunately as it it’s confidential :frowning:

Thank you for your help!


Here it doesn’t work:

And now it works when treating these rooms separately:

A file would be helpful but, from your screenshots, I sense it likely is not an issue with your geometry and it might just be a data tree management issue. Have you tried flattening all of the inputs to the HB Add Subface component?

Hi @chris, thank you for the quick reply.
Here is a part of the entire model.
All inputs of the HB Add Subface component are flattened.

In the first case, 4 windows are missing:

But when these four windows are treated separately, they are successfully added: (41.5 KB)

The file is using additional non standard plugins. It is not working as the geometry is not showing.
Better internalize it without those plugins.

So sorry I thought I had attached a different file!
It should work fine now.

Can get the time to check this more thoroughly, but i get into a solution that all windows are in:

Extracted the 4 problematic windows from the list and joined them to those that work.
This can be related to some tolerance value. Didn’t tried to change this value in the Units options.
I suspect those windows are not well aligned to the wall face.


To confirm my suspicion, see those images with a very close zoom in.
Good window, looks well aligned to the wall:

Bad window, not aligned. Looks it has a bit of inclination (not perfectly vertical):


1 Like

Thanks for figuring it out, @AbrahamYezioro . Apertures have to be coplanar with and fully bounded by their parent Face in order to be valid. If I open you original file, @BlueMeadows , while the Rhino model tolerance is 0.01 and angle tolerance is 1 degree, then all of the apertures are added.

So using a coarse model tolerance could fix it but the best way to address it is to just remake the geometry at the model tolerance that you’ve been working at, ensuring your geometry is coplanar as you build it.

1 Like

Thank you for your help @chris and @AbrahamYezioro!