After updating LBT 1.4.0 Energyplus doesn't work well (file attached)

Hello, everyone.
I am using LBT Tools AND Honeybee since HB was 0.666ver, and I updated LBT 1.3.2 to 1.4.0 today.
Everything was fine, I’ve checked compatibility matrix, and all components in GH file get synchrnized to 1.4.0 ver properly. AnnualDaylight simulated well too.
I am simulating AnnualDaylight and AnnualLoads components to optimize UDI and annual energy loads, But AnnualLoads doesn’t work well. Here’s error messages showed:

220114_dimming (788.2 KB)

also that pop-up message said [1. Solution exception:database is locked]

thank you for any response!!

1 Like

This looks like a permission issue. Do you have read/write access to that folder? Any change that you have that folder open on your machine which stops Ladybug to be able to modify them?

I’ve checked what you said. did you mentioned about these one, right?

(it’s Korean, but i believe you know what it is.)
every access rights- read, write and other things have allowed.
and i didin’t modify anything related to this folder after update…

and also, i have used another PC that has exactly same compatibility matrix (LBT1.4.0, E+9.6, Openstudio 3.3.0, radiance 5.4a 3-28 released) to simulate the same file i attached above, AnnualLoad works.

Also, I simulated same file above i attached in 3 different PCs which have same environment, but same errors occurred in each PCs though.

in different model, the same error occurred. i’ll attach gh file. (264.0 KB)

It’s not an issue that I (or probably anyone else) can easily recreate since it likely results from you having that Annual_Loads folder open in another program on your machine. Can you manually delete it? After you do that, you probably won’t have this issue anymore unless you open those files or that folder in another program again.

Whatever the case, I’m pretty confident that this doesn’t have to do with a change that was made in LBT 1.4.

Actually, I uninstalled energyplus, openstudio, radiance and LBT 1.4.0 and re-installed them several times on 3 different PCs(they are all enough to simulate HB things) to make it sure that it’s not caused by 1.4.0 but same error i described above occured everytime.
I also hope it would not LBT 1.4.0’s problem, But after down-grade LBT 1.4.0 to 1.3.2, AnnualLoads and UDI simulation works well.

it’s programs that i installed when i upgraded LBT 1.3.2 to 1.4.0:
Energyplus 9.6.0
Openstudio 3.3.0
Radiance 5.4a (2021-3-28 released)

and programs i have installed with LBT 1.3.2:
Energyplus 9.5.0
Openstudio 3.2.1
Radiance 5.4a (2021-3-28 released)

I checked all compatibility matrix and manually installed them.

Hm. It’s just not an issue that I can recreate on my machine:

Did manually deleting the Annual_Loads folder not fix it?

Hi there,
Were you able to fix this problem?
I am encountering the same problem at the moment…

@linkimim ,
Did you try manually deleting the folder at:


Thank you very much! It is useful!