Annual daylight simulation - ValueError: "CreateOctree" failed. oconv: system - out of octree space

Hi guys

I’m working on a daylight project, where I keep getting the following error, at step 7 of my annual daylight simulation.

ValueError: "CreateOctree" failed. See below for more information:

oconv: system - out of octree space

2023-12-19 08:56:19 DEBUG: Asking scheduler for work...
2023-12-19 08:56:19 DEBUG: Done
2023-12-19 08:56:19 DEBUG: There are no more tasks to run at this time
2023-12-19 08:56:19 DEBUG: CreateOctree___cpu_count___8__8e57280858 is currently run by worker Worker(salt=4389589436, workers=8, host=HPC89, username=MarkLabrosse, pid=3852)
2023-12-19 08:56:20 INFO: Informed scheduler that task   CreateOctree___cpu_count___8__8e57280858   has status   FAILED
2023-12-19 08:56:20 DEBUG: Asking scheduler for work...
2023-12-19 08:56:20 DEBUG: Done
2023-12-19 08:56:20 DEBUG: There are no more tasks to run at this time
2023-12-19 08:56:20 DEBUG: There are 8 pending tasks possibly being run by other workers
2023-12-19 08:56:20 DEBUG: There are 8 pending tasks unique to this worker
2023-12-19 08:56:20 DEBUG: There are 8 pending tasks last scheduled by this worker
2023-12-19 08:56:20 INFO: Worker Worker(salt=4389589436, workers=8, host=HPC89, username=MarkLabrosse, pid=3852) was stopped. Shutting down Keep-Alive thread
2023-12-19 08:56:20 INFO: 
===== Luigi Execution Summary =====

Scheduled 15 tasks of which:
* 6 ran successfully:
    - 1 CreateRadFolder(...)
    - 1 CreateSkyDome(...)
    - 1 CreateTotalSky(...)
    - 1 GenerateSunpath(...)
    - 1 ParseSunUpHours(...)
* 1 failed:
    - 1 CreateOctree(...)
* 8 were left pending, among these:
    * 1 were missing external dependencies:
        - 1 PrepareFolderAnnualDaylight(...)
    * 1 had failed dependencies:
        - 1 _AnnualDaylightPrepareFolder_28ff6c38Orchestrator(...)
    * 5 had missing dependencies:
        - 1 AnnualDaylightRaytracing(...)
        - 1 LetAnnualDaylightFly(...)
        - 1 PostProcessAnnualDaylight(...)
        - 1 RestructureResults(...)
        - 1 _Main_28ff6c38Orchestrator(...)
    * 1 was not granted run permission by the scheduler:
        - 1 PrepareFolderAnnualDaylight(...)

This progress looks :( because there were failed tasks

I’ve attached the log, as I can see from previous posts, that this is what our awesome LBT team usually requests in these instances.

logs.log (219.2 KB)

The file is only 0,156 GB, so I doubt that the size is the problem. To me, it sounded like harddisk og RAM space was the problem, but I have about 80 GB available space, have 32 GB RAM on the computer and has monitored the the RAM use and the RAMs aren’t maxed out at any point.

I only use 8 out the 12 available CPU’s for the simulation.

I’ve been trying to fix the bug myself for almost a week without any progress, so any guidance is appreciated :sweat_smile:

Hi @MarkLabrosse, I have never seen this error, and I have dealt with very complex models! If I have to guess, you probably have some items that convert to meshes with 1000s of small triangles. See this discussion on the Radiance forum:

As usual, if you can share the model we can have a close look. I’m testing the shade models right now, and this might be a good sample file to test it against.

Hi friend

That sounds interesting. I don’t see what geometry might create such dense mesh as I’ve manually simplified most of the frames and used the SelSmall Rhino function to remove small geometry like door knobs etc. But I never visualize the faces of the mesh, so I actually wouldn’t know.

I’ll send you two different models

  1. Small model - This is the last one I’ve used. Deleting surrounding geometry reduced the file size from 0,46 GB to 0,16GB
  2. Larger model - Without removing surrounding geometry

Both models have been simplified significantly as mentioned above.

I’ve anonymized the naming etc. so I don’t mind sharing the model publicly.

It would be great if replacing the HB Face component with the HB Shade component solves the issue! If it solves the problem, it would also be interresting to look into the raw exported model. But let’s look into that when we get there.

Hi @MarkLabrosse,

I noticed that the unit system is millimeters. Did you change the unit to meters or scale the model in Grasshopper before running the recipe? I did not try to do it on your model myself, but sometimes weird things happen if you use a model in millimeters for Radiance.

Hi @mikkel and @mostapha

I just tried rerunning the simulation. I changed the model units to meters (and let rhino rescale the model in doing so) and used the new HB Shade component. However, I still received the same error

Hi @MarkLabrosse,

I can run the small model without issues. Can you share the model folder? You can find it in the project folder.

1 Like

Hi mikkel

Sure, you can download it here: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Thanks, @MarkLabrosse.

I get the same error when running the CLI command to generate the octree. I was able to run by increasing the -n value in oconv. But it is probably better to look at the model export. Are you able to share the Grasshopper file with internalized geometry either here or in a private message?

I just send the script to you in a personal message. Thanks :+1:

1 Like