Another issue with LB and Rhino WIP

I can’t get Rhino 6 to work with the sunpath tool. I followed the thread here:…

and still couldn’t get mine to work. I cannot figure out how to get grasshopper to run Ironpython 2.7.7, if that is indeed the fix. I have changed the search directory in the python editor and uninstalled ironpython from the control panel. Both of those things area beyond my scope of knowledge, and I may have messed them up.

Error info below:

Hi Scott,

NotImplementedException was not there in Claudio’s case. Can you please share your file? I am assuming you have latest / stable version of Ladybug_Ladybug on canvas. Also, did you try Ironpython 2.7.5 ?


Thanks for the quick response. File attached.

I also think I’ve never actually been able to get 2.7.7 working; see images below. I tried following along with Claudio’s forum, but really couldn’t figure out how to work the IronPython install at all. Took a few stabs and moved files around, but I didn’t really know what I was doing… (388 KB)

Hi Scott, I checked the issue and it’s happening because Explode method is not implemented for TextEntity in Rhino WIP. I tried a couple of other solutions but seems there is no other way to get the geometry for the text. We can catch this error and generate the sunpath but there will be no text. Is that going to be helpful for your work?