ASCII error with HB Model to OSM

  1. Solution exception:Failed to write in.bat to file:
    ‘ascii’ codec can’t encode character ‘\u4F59’ in position 122: ordinal not in range(128)

Hi,I have no idea what is going on. I installed the Tools according to the instructions. When I tried to run it, the problem suddenly appeared. No matter how many times I reinstall it, it still looks like this.

It looks like there’s a non-ASCII character in the directory that you connected to _folder_ and Windows .bat files can’t handle this. Just use the default _folder_ or a folder with all ASCII characters and your simulation should be fine.

Thanks Chris, but this program can run on another computer with this folder. It’s really weird.

And it’s still not work.

Well, I know that changing the folder to something with all ASCII characters should fix it but I’m sure there are also other ways to fix it.

I wouldn’t know as I haven’t used an operating system in a language other than English but maybe there’s some setting on your operating system like that described here that would fix it. Is your Rhino installation using the same language setting as your operating system?

They’re in the same language setting. Maybe I have to reinstall my system. T T

I should also clarify that you probably need to change something other than the simulation folder to be all in ASCII characters. I suggest using the “HB Config” component to check where OpenStudio and EnergyPlus are installed since the paths to those might contain non-ascii characters.