BF failing to generate 'SimpleFoam.err' file

  1. Hi, I am returning errors when I try to run any BF tutorial. It seems that the ‘SimpleFoam.err’ file is not generated inside the log folder. Any ideas? Below is my error and thank you:

Time = 6

smoothSolver: Solving for Uy, Initial residual = 0.5378333, Final residual = 7.5936467e+024, No Iterations 1000
smoothSolver: Solving for Uz, Initial residual = 0.52501375, Final residual = 3.1806038e+024, No Iterations 1000

  1. Failed to read C:\Users\brobe\butterfly\outdoor_airflow_2d\log\simpleFoam.err:
    [Errno 2] Could not find file ‘C:\Users\brobe\butterfly\outdoor_airflow_2d\log\simpleFoam.err’.: C:\Users\brobe\butterfly\outdoor_airflow_2d\log\simpleFoam.err
  2. done!

Also, I am running the latest version of BF from BlueCFD.

Any suggestions ? Thank you

Alright, I reinstalled butterfly and have gotten the ‘outdoor simulation’ tutorial working with no errors. Will keep testing. Just to survey…

The ‘Indoor Simulation 2D’ throws a ‘Windows Error’ on the Snappy Hex Mesh after writing it.
The ‘Indoor Simulation’ ends after 202 iterations and then throws the previously mentioned 'could not find SimpelFoam.err (It should allegedly go to 606 according to the tutorial).

So some examples are working while others do not. Is there any guidelines or advice a forum member can offer? Thank you

The message is misleading! It just says it can’t find the error file since there has been no errors. I should probably remove the message for the report. It has been confusing for several users.

1 Like

Thanks for the reply @mostapha. It seems that there might be some truth in the SimpleFoam.err message as it does not allow the solution to converge. If this error is misleading, what else could be causing every example not to converge after throwing the above error?

Possibly is there a problem with my blueCFD? Here is an image of it.

Thank you.

I had issues with log and error files. My problem was that my standard user folder was on a seperate drive (D-drive). Is this also the case with you?

From what I can see it stops after 1000 iterations which is probably the number of maximum iterations. If you maximize the number then it will keep running.

@Laurens - I have my butterfly folder installed on my C drive at : C:\Users\ebroberg\butterfly

Hi!!

I am totally clueless what went wrong. I tried to generate the solution but it only run 1 iteration and stopped completely even though I set to end time 600.

The error shows:
"FOAM Warning :
From function virtual void Foam::probes::findElements(const Foam::fvMesh&)
in file probes/probes.C at line 119
Did not find location (117.43934 -101.12856 26.927351) in any cell. Skipping location.

And also:
could not locate “simpleFoam.err” file

I am not too familiar with CFD but the snappyhexmesh run seems normal with no error log. Its only when i run the solution then the error above appears. Would really appreciate any advice on what had i done wrong?

outdoor_airflow test.gh (745.7 KB)

Hi Joey and everyone. Have you found the solution? I’ve also experienced the same error message. The solution stops in iterations 2, while the max iteration was set to 1000. Any advice would be very appreciated.

Thank you very much.
Regards,
Astri

Hi Astri
Apology for my late response. I read about the version incompatibility of latest Blue CFD-Core (version 2020) which does not work well with Rhino 7. Hence, I replaced with Blue CFD-Core 2017 which then the simulation worked. You may want to try out if you are using the same version I did.

Hello community

I reactivated this post because, using the CFD-Core 2017 and Rhino 7 it still says this error.
SnappyHexMesh report says “Finished meshing without any errors”
But when I run de Solution, it says in all lines "Did not find location (coordinates) in any cell.

Also I open first the blueCFD-Core 2017 terminal as administrator

Any idea?

Best regards!

@gonchotorena mayb u can share the file so we can appreciate the issue? Im not too conversant but i can try n help wherever i can.

Thanks @Joey_L for your help,

I attach the file,

Any opinion is welcome!
1-4 CFD_Consulta.gh (48.8 KB)