Blinds glare control

Hi all,

I am trying to control the blinds depending on glare issues, not pure illuminance. However, I am finding that it doesn’t matter what I put in the DSGlareControl, it is always overwritten by the DSShadingState

I thought that maybe the HEA file was written different from what is says in the Daysim manual, but I have only seen some intro differences, what I don’t think would cause much trouble. Being:
Daysim manual example:

My HEA file:

It doesn’t matter what I put in the glare recipe, the blinds always follow the max illuminance (even if I put its max threshold 20000lux over the glare recipe threshold). As glare is view dependent I also added a rhino view and so on (it made my simulation so long I would automatically discard this option, but…) and still didn’t work.

I would be happy also making the blinds follow a schedule, but I don’t find how to do this anyway…

Could anybody give me a hand with this?
This is my GH file: (694.8 KB)

And no, I haven’t tried honeybee[+] as for some reason it doesn’t want to work for me and didn’t have the time to make it work.


@mostapha? Any idea?

Hi @JuliaT, Sorry for the late reply.

I can hear your frustration but if the number of sensors is as much as what you have shared in the sample file I would be happy to help you get it to work with Honeybee[+]. I personally prefer to spend as minimum hours as possible figuring out Daysim. If Honeybee[+] is a no no then let me know and I can have a closer look.

Hi @mostapha I finally I spent a bit of time and made honeybee [+] work.
However, my problem still remains, the only way I find to control the blinds is with an illuminance threshold, neither glare or a schedule. How can I get these options to run? (625.8 KB)