BlockMesh + Windows Error

Hi there, I installed the latest version of Butterfly and it worked well with “outdoor airflow 2d” example file, but I got the windows error when I tried to run the “indoor airflow 2d” file.
I checked the same solutions but none of the them were practical. Here is the full report of the Blockmesh component. I’d appreciate your help.

@Qodsiye, you can check my solution here:

@thomas.wortmann,Thank you for your reply. I tried this solution but I’m not sure if I understood the process correctly:

I copied this code:
self._project_folder = os.path.join(os.path.expanduser('~'), 'butterfly', self._project_name)

and pasted it into line 45 in

Are there any other steps that I missed to check?

Looks good to me, does it work?

@thomas.wortmann, it didn’t work for me, unfortunately.

@mostapha Sadeghipour Roudsari, could you please help me?

You can use the Python component in the attached Grasshopper definition to check whether the file path is causing the problem or not. The results should be indentical. If they are not, my solution should help.(To be clear, you need to replace line 45.) (2.3 KB)

@thomas.wortmann, So many thanks for this component, I checked it and the result are identical10%20PM

Hi - I’ve never used Butterfly and have barely read this thread but just in case…
Those two strings are not identical. One is with a capital C, the other with small c.
I wouldn’t be surprised if “things” were case-sensitive…

@wim, Hi - Thanks for getting back to me… actually I identified the problem but I do not know how to resolve it.

Hi there–

I have the same issue here…it runs an error and I don’t have too much Py knowledge.

Could anyone help me on this?


Hey anyone got any updates to this? It’s been two years, still no resolution?

Hi Wim,

So I know a bit of coding and I opened the component. The C being lowercase is but an issue of the python itself being typed into lowercase. However, this identification hardly solves the issue. Most people had the issue immediately resolved using this Line 45 solve however I have never had this issue before and it suddenly popped up today. I have everything running on admin mode. Do you have any further bright ideas?