blueCFD-Core Installation Issue


#1

Hi,

I previously had issues with installing OpenFoam on my computer. I tried downloading through blueCFD as instructed on the butterfly page. The terminal runs fine but butterfly is still giving a “‘docker machine’ is not recognized error”. Do I have a chance to make this work on my machine?

Thanks!


#2

hi @sshahi

Could you try uninstalling completely Openfoam4windows and its depencies as describe here:


#3

Same problem is faced by me when running the first example of butterfly.
i had tried the following you mentioned but i cant find .docker and .virtual machine.
i think they aren’t installed in my pc.
should i need to install them separately. if so, where can i find this.
hope you will come up with a workable solution.

thanks in advance


#4

The latest version tries to find the blueCFD installation and if it can’t it will try to use the OpenFOAM for Windows. By default it assumes that blueCFD is installed under C:\Program Files which you can change by overwriting this line in __init__ file.

I assume that in both of your cases butterfly has failed to find the installation. Try to run the commands below in a GHPython component and see what is the results:

import butterfly
print(butterfly.config['runner'])

Butterfly installation problem
#5

Dear Mostapha,

I changed the address as you mentioned in the init.py file to the exact location of blueCFD.

I also tried to try the command in a GHPython as you asked, unfortunately the error is that “there is not attribute config”

I looked at the error in blockmesh python component, a couple of them that I can see are all traced back to runmanager.py in line 100, getShelinit or line 112 getContainerId and line 60 of ContainerId all related to the docker machine, from what I understand the docker machine was related to the previous OpenFoam and should not be the case with BlueCFD.


#6

Just to add to this discussion, the butterfly version in food for rhino is march 2017. Is it to be updated to some more recent updates with update butterfly component before it works with blueCfd?. Which version date butterfly is up to date?

Thanks in advance


#7

Hi,@Asisnath
You can install the newest version of butterfly using this link:


#8

I installed it and running successfully with bluecfd core. I downloaded the legacy version from food for rhino here. https://www.food4rhino.com/app/ladybug-tools
I updated the butterfly component from Github from https://github.com/ladybug-tools/butterfly and butterfly(+) component from https://github.com/ladybug-tools/butterfly-plus to the respective directories.


#9

It should be the parent installation folder not the folder itself. Which means C:\Program Files and NOT C:\Program Files\blueCFD-Core-2017.

That means that Grasshopper is still loading the older version of Butterfly from the cache. Start a new instance of Rhino.


#10

Hi Asisnath,
I’m glad to hear that u ran successfully with bluecfd core. I think I also installed it correctly, but it run super slow both in mesh block and solution component. And my imput geometry just simple 2 boxes as it default geometry


you can see the time in right part. Nearly 90s for each time loop, I have no idea when will it finish.
since it almost have hundreds time loop in total…
Do you have any ideas?


#11

hello @hazel initially i ran into same time consuming issue. But i updated my butterfly components from github and its working perfectly fine and in less time compared to earlier.


#12

Hi,Asisnath,
Thank u so much for your answer!
may I ask one more question? (my butterfly0.005 is the latest version which i download from food4rhino)
As u said, now I have already down load the butterfly update files,one called butterfly-master and another called butterfly-master-plus, what should I do next? how to update the component. thank u for ur patience, I’m totally new to parameter area. :slight_smile: