Bug with Grid Filter - version 1.5.1

Hi All,

I’m unsure why this isn’t working anymore, but I believe it may be a bug from the latest version as I have just updated from 1.4. to 1.5.1 (having put it off for a bit now in fear of ‘breaking’ working files…) and the grid filters have worked well before now. When I remove the grid filter, the annual daylight metrics component works with no issues, however when I add a grid name to test, it throws up an error “1. Solution exception:Failed to compute annual daylight metrics.”

Has anyone come across this, or have any tips to how this should work now perhaps?


Maybe i’m seeing wrong, but from the second image it looks that you are connecting a mesh output to the grid filter. If so, this is the cause of the error.
Can be that?

I wish that were it, but no, I’m grabbing the name for one of the grids ‘Primary_L1’. The same error happens if I just have “Primary” or “Secondary” or “L1”. It just seems to have an issue with stating a grid filter.

I went back to an old file with 1.4.0 versions, and annoyingly now the results won’t even come through - complaining of a “1. Solution exception:Could not find file ‘C:\00ProjectBackups\Daylight_Template\annual_daylight\results\Primary_L1.ill’.” error. It has a different name to the previous file name, so shouldn’t have an issue of overriden work…

Bit nervous now to go back to my old projects to do updates.

I have changed my versioner to 1.5.0 and synced the whole file to that, and its working to move on. However, it does seem like the issue may be with the 1.5.1 version.

Looks like one for @mikkel. I’m not at my laptop atm, but from the error message I believe daylight results are now held as .npy files instead of .ill in the latest version. It might be a bug or you need to sync your file?

There’s been a few bugs raised recently around daylight, it seems Mikkel is doing a lot of work on the back end and has quickly been fixing bugs as they’re found

Well, this is working for me with the latest version, like so:

Used the annual_daylight sample file.

Hi all,

I believe this is a bug that occurs for grids created from geometry, as in @ElzineBraasch’s workflow. That is why the sample model runs without issues - thanks for testing that, @AbrahamYezioro. This should be a quick fix which I will try to get to later today.

Hi @ElzineBraasch,

If you run LB Version (without any version) you should get the fix I pushed. Let me know if you are still facing issues.

1 Like