Butterfly_atrium buoyancy example file_strange vector results

I am trying to run the butterfly example file “atrium buoyancy”.
It ran well yesterday, but today it is giving me strange results. the velocity vectors are haywire as in the attached picture. I checked the scale of vector but it doesn’t have error there.I did same yesterday and today, but the result is different.
Yesterday, there was another error. Whenever I used parallel run for snappy hexmesh FOAM fatal error occured.Therefore I stopped using “decomposepardict” component.
Thanks in advance04_atrium_buoyancy4.gh (461.2 KB)


Attached is the error message I was getting yesterday, when I ran “Decomposepardict” .

decompose par dict2

Hi @anupamarana

This usually happens when 0 folder is not renamed to 0.org while decomposing before meshing the case. Did you run anything manual while preparing it or was it all through the GH script? Can you try deleting and starting over?

If none of that work, I think it might be smth to look into.

Kind regards,

Hi Theodoros
I didn’t run anything manual, it was just all through the GH Script. I repeated by deleting and starting the example GH file but it was either Dicomposepardict and/or haywire vector plot error again. I checked all of other outdoor simulations i had done in butterfly but none has 0.org to run parallel CPUs, yet they ran smoothly. Is 0.org required for indoor simulations to use parallel CPU’s?

RIght now I am running butterfly for another indoor case but with bigger and heavier mesh, it will take longer time. After that I’ll try running the Atrium buoyancy example file again and follow your instruction and update you.

Thanks a ton for such a prompt reply.

Best Regards

@anupamarana and @TheodorosGalanos

I’m getting the same exact error message when I run buoyancy example file.
Have you or anyone found out what was the problem?



I was able to get the buoyancy example file working.

For the error message raised by anupamarana had to do with pc configurations like how many CPU your computer has. So disconnecting decomposeParDict component solves it. For the strange vector result part is related to the scale issue. You can fix it by adjusting the slider that’s connected to Vector Display Ex component at the end of the definition. I’ve attached the definition that I adjusted. I’ve changed a few other thing here and there but it should work if you run it with rhino unit set to meter.


04_atrium_buoyancy_adjusted.gh (464.2 KB)


Thanks for letting us know @yoshikawa! Indeed you must make sure you enable multiple CPUs in the VM box in order to run things in parallel.