Butterfly Block Mesh error


Thanks for this awesome work.

I’ve been following this discussion and decided to open a new one so issues don’t get lost.

I followed Mostapha’s advice there and replaced the runmanager.py as instructed.

Now i’m getting the attached error.

I’m using both Outdor_airflow and HumanUI_OutdoorCFD examples.

Any recommendations?



Hi Abraham, Great to see you’re getting started with Butterfly. You just need to update butterfly. Check here for more.

Hi Mostapha,

Thanks …

But no success. After updating i get a different error:

So i tried running manually the start_OF.bat as per this discussion.

Still no success. See left side and right side of the following image. Tried running with different shell windows since the BAT file closes.

Any ideas?


Hi Abraham,

Based on the screenshot OpenFOAM is not installed correctly on your machine. Does the folder exist on your machine? C:\Program Files (x86)\ESI\OpenFOAM\1606

Oh yes!! There’s where i run the start_OF.bat.

I installed OF also in a desktop and i recall seeing that for this computer i need to change something on the BIOS. Can be related here too? I don’t remember what it be … any clues?

I don’t like touching the BIOS … this is a mine zone :slight_smile:



That was a dumb question. I can see the folder actually on the left.

I’m not sure about the problem. This discussion may help. Also have you searched for the problem on cfd-online?


Hi Mostapha,

Probably the dumb questions are on my side …

Some progress was made, but still standing on the same spot.

Updated BF, restarted Rhino and GH = No results.

I enabled the VT-X/AMD-v in the BIOS as i noticed that i was required to do so. This is the progress i made. Now the file “do something”. It takes about 4 minutes in the blockMesh component, so something is happening. But at the end of the 4 minutes i get the same error as before. Tried to run the start_OF.bat externally, but no use either.

Those are the snapshots of both of them:

Be patient … and bear with me. Sorry for bothering with this … and thanks,


P.S. There is a chance it is related to the firewall of my university, or some other security issue for those trying to apply virtual machines/hosting.

I’ll try at home in the evening.

A more detailed image of the shell running the batch file manually:

Hi again,

Trying on my desktop now.

Needed to uninstall and reinstall OF(After changing the BIOS the computer crashed on restart and also needed to recover it from a previous restore point. Hopefully it will be fine).

Still get the error in blockMesh. When running manually the start_OF.bat now i get this image:

I feel that there is a small progress but … not there yet.


Hi Abraham

I had the same problem, at the end, restarting and re-running OF_Env_Create worked.

you probably already tried it.

BTW for me, it worked on a desktop, on my laptop I gave up.


Hi Hagit,

Yes. I’m starting to get manage in the desktop.

Now it get stuck at the BF_loadProbes components, as you mentioned in this discussion. The difference is that no U or P values for both components. I was thinking that it is necessary to install the Paraview software, but i see that no need (for this issue).

The laptop, as you said, is still refusing to cooperate, even though i uninstalled and reinstalled OF (as i did in the desktop).

For the illustration, this is an image with the error in the desktop:


For some reason i can’t reply to your last message, anyway -

first, try to connect the data and case name to this component (load probes from project):

you have to connect the case name and not the data itself, and the field name.

that will take you one step further and you’ll be stuck with the rest of us.

צרת רבים נחמת טפשים

Hi Abraham and Hagit, An update should solve all these issues.

Abraham in your case butterfly is not updated. Make sure butterfly last updated is 2016-08-23 10:45

Hi Mostapha,

Good news from my side: I get manage to run one simulation fully (indoor_airflow example) on my laptop.

My first conclusion from my process to get there is: READ CAREFULLY THE INSTRUCTIONS!! I could save a lot of time if i did.

I recommend to add the install OF Readme to the recommendations thread. Specially people need to pay attention to the prerequisites (virtualization). Second of all, in case you uninstall and reinstall, before the later, be sure you delete the c:\users\YOUR_USER_NAME.docker and .VirtualBox. It took me 3 installations and 2 uninstalls to make it work.

Now i have a question not related to the thread. Once i get the results, how can i use them without running again. This is a very dumb question, but i don’t see the right component and input to do so.

And another thing. It is me or after the simulation is done (in the BF_simpleFoam) the GH canvas is behaving slowish? You can sense it pretty much.

Hagit: Not stuck :-). It is working. Tomorrow i’ll try the outdoor example, which i see is your case.



Hi Abraham,

Great to know! I added the link to the page.

‘Load Probes from Project’ should load the results for you without re-running the analysis.

Are you connecting the readMe output from simpleFOAM to a panel? It prints so many lines and that can slow down GH.


Hi Mostapha.

Loading results works fine.

I disconnected the panel from the simpleFoam and now the slowness is fine.

A couple of questions more:

I get results for each 100 iterations. Can i see them?

I don’t succeed to see the mesh. I follow the instructions on the Getting Started page but in each try the mesh and pts outputs are null for the loadMesh/Pts components.



Ohhh. It is going to be painful :slight_smile:

I managed to see the mesh and points. What happened is that i asked to compress the results before writing them. The component doesn’t know how to read the compressed files. Though the results themselves can be compressed and represented.


Hi Abraham,

Thank you for reporting back. Butterfly should be able to unzip and visualize the results if they are zipped. I add an issue to github: