Butterfly Blockmesh component error

Hi. I have installed OpenFoam. However the error of Blockmesh component appears in all the example files when I open them. The error message is:1. Solution exception:‘ascii’ codec can’t encode character ‘\u59DA’ in position 106. And other example files are the same.

Runtime error (EncoderFallbackException): ‘ascii’ codec can’t encode character ‘\u59DA’ in position 106

line 206, in _run_ironpython, “C:\Users\ym\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\runmanager_bluecfd.py”
line 234, in run, “C:\Users\ym\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\runmanager_bluecfd.py”
line 756, in command, “C:\Users\ym\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\case.py”
line 788, in blockMesh, “C:\Users\ym\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\case.py”
line 52, in script

Can you please share the GH file?

Just a guess: This might be caused by running a non-English Windows.

It is the first exmaple file “01_0_outdoor_airlflow” in butterfly examplefiles folder downloaded from Ladybug Tools. But I have solved this problem, thanks!
01_0_outdoor_airflow.gh (432.3 KB)

Thanks! You are right. The file path contains non-English words. I have created a new Microsoft account and now it works well.