Butterfly cannot run correctly

cfd-outdoor

#1

Hi all,

Recently, I tried to test Butterfly by following the tutorials using the example file of outdoor_airflow. Unfortunately, I never got correct results as the tutorial shows. the VirtualBox and OpenFoam work fine, initially I didn’t change any components but just add toggle button to run snappyhexmesh, then I got:

  1. the SnappyHexMesh run super slow and sometimes reports a large number of error faces(the other times 0 error, quite weird);
  2. If connect the SnappyHexMesh component to LoadMesh component, Rhino is not responding;
  3. the Solution component gives incorrect results, and the probes value are all zero.


    later I notice some components in the example file are old version and try to update the components manually to latest version but it can not help.

Do anyone have ideas to solve the problems? Thanks so much for sharing your solution!
I found a similar question in the Forum so I link it here

Best regards,
Guo


#2

Hello GUOX,
have you checked your units.It should be in meters and also check the probe values should be on planes minus the structures.


#3

Hi Asisnath,

Thanks for the reply. The unit is meters, I check it many times. I will try to keep probes within the structures.


#4

Please check the residual values and log values for validation.


#5

I check again, unit is meter and the probes stay in the plane minus the boxes, but it is still producing incorrect results…

I share the original file below, maybe you or someone could find out what goes wrong. Anyway, really appreciate for your time!

01_0_outdoor_airflow.gh (532.6 KB)


#6

I have redefined some definition , i hope it will work. 01_0_outdoor_airflow revised.gh (537.2 KB)


#7

Hi @Asisnath, already receive your file, thanks a lot! But I am afraid I am not able to test it right now because I met another problem recently which drives me crazy…

After I restart my laptop, the OpenFoam throws me an error as below:

I try to reinstall everything many times but the installation is always failed when waiting for an IP, and finally the error is still there. Also try several solutions online but none of them work.

I know nothing about docker so I have to give up fighting with this problem by myself…
I am wondering if you have any ideas about how to solve this problem? Thank you!


#10

TRY THIS.


#11

I followed the recommended steps, still failed.
It seems to only way is to format the hard drive and install everything again.:thinking:
Anyway, really grateful for your help!


#12

HI @GUOX,
Did you run Oracle VB and Docker prior to opening OF?

The steps I go through to make everything run correctly are as follows:
(everything with administrator rights)

  1. Oracle VM VB
  1. keep Oracle running, open Docker

  2. Keep Oracle and Docker running, open OF_Env_Create

  3. When I see this window close it and run OpenFOAM

But I’m just trying to run butterfly myself, so not 100% that it’s the right approach.

AB


#13

Hi, @ale_bog,

thank you for the detailed reply. I tried your solution this morning, still nothing changed. Actually, from my 20 times re-installation experience, the problem has something to do with the IP address in running the .exe file of “OpenCFD-OpenFOAM4WindowsInstaller_v1612+.exe”, almost everytime it will stuck in the step of “waiting for an IP” for a long time and later the error appears, no matter to run Oracle VB or docker tools or OF first. Just a guess, I know nothing about docker.
Anyway, thank you very much for your kind suggestion.

Kind regards,
Guo


#14

@GUOX
btw I had issues with 1612+ too, but tried 1806+ and it works on both machetes that I installed it on.