Butterfly failed to run

installation

#1

Hello everyone,

I reinstalled my OpenFoam and VM recently and from then the following errors started popping up with every CFD I run. The errors are:

Error1

  1. Solution exception:Failed to find points file at C:\Users\Neeharika\butterfly\outdoor_airflow\constant\polyMesh

Error2

  1. Solution exception:Failed to load values:
    Failed to find probes folder folder at C:\Users\Neeharika\butterfly\outdoor_airflow\postProcessing\probes


Any suggestions how can I overcome this error

Thank you

Neeharika-outdoor_airflow-Error.zip (17.5 KB)


#2

Neeharika,

The folder runs with no issues on my machine. There is an issue with you installation. Follow these lines in the command line and tell me what happens.


#3

Mostapha,

I did enter the first command “cd workingDir/butterfly/outdoor_airflow/” and it says no such file or directory.


#4

Then I would check create case component and see where the folder is created.


#5

Create case component shows that folder is created in the right location.


#6

This means the VM and butterfly are looking into two different folders. Did you install VM and OpenFOAM both as an admin?


#7

In my case, I have only one user account system, so I installed both the OpenFoam and VM just by double clicking on the setup file.

One thing I want to make sure is that, by installing as an admin do you mean that even while installation I need to run my setup file as an admin?


#8

Yes.


#9

Hi Mostapha and Neeharika

I am trying to test run the 01_0_outdoor_airflow file downloaded from github and I am having the exact same errors like Neeharika.

  1. Solution exception:Failed to find points file at C:\Users\Danijel.Rusovan\butterfly\outdoor_airflow\constant\polyMesh

  2. Solution exception:Failed to load values:
    Failed to find probes folder folder at C:\Users\Danijel.Rusovan\butterfly\outdoor_airflow\postProcessing\probes

Installation of OpenFOAM 1706 was really painful as docker toolbox downloads the latest boot2docker.iso (think it is 1.8.0 or something like that) which has a bug - it doesn’t start the default machine after you power it off (even if you download the earlier version of docker toolbox the .iso file still gets updated automatically). The error message was like the sample one below (sorry I don’t have a screenshot):

Error response from daemon: container “0bab935448d88f2e3323cfc94a91b48e661d2eec08ac5a7359e71bf59d813211”: already exists
Error: failed to start containers: oracle-xe

I have also installed the latest VM 5.2.6 (I had to uninstall the one that comes with OpenFOAM 1706 as it was giving me errors)

I have followed your instruction for Windows 10 installation as per webpage

I have then manually deleted the boot2docker.iso in following folders:
C:\Users\USER*.docker\machine\cache
C:\Users\USER*.docker\machine\machines\default
C:\Users\USER*\AppData.docker

WITH:

boot2docker.iso file downloaded from this website:


(make sure it is the stable version and not a pre-release one!)

After all this witchcraft, I managed to start and power-off the default machine in the VM and OpenFOAM Start would work with no issues. However, when I tried to run butterfly it didnt work - error messages as above.

I have followed the lines as per your suggestion above and this is the output I get.


Hope you have any suggestions what to do/try next? I am having the same problem of both my private and work PC (Windows 10) :confused:

thanks a lot for your help!

Dan


#11

Hi @DanijelRusovan, I blocked tomorrow to work on Butterfly and the first step will be working on alternate installation solutions. I will keep you posted.


#12

Hi @mostapha, sorry for being inpatient here - was just wondering whether you had a chance to test some alternatives?

thanks a lot!

Dan


#13

It’s not you being impatient. It’s me not being on-time. I haven’t had the chance to do it yet but it is on top of my list. Will keep you posted.


#14

@DanijelRusovan, I totally underestimated the amount of administrative work that I have to do for the workshops. Unfortunately I didn’t get a chance to work on updating Butterfly. My apologies and I hope to get it done early in April after the workshops.


#15

@mostapha thanks for letting me know! Hopefully it will be solved soon! :slight_smile: I’ll try to install it from scratch a few more times while waiting :slight_smile:


#16

@mostapha, I managed to get butterfly running without issues.

I have first installed docker toolbox DockerToolbox-17.12.0-ce (with VM) and then openfoam (when openfoam installer tried to re-install dockertoolbox I hit cancel so it doesnt affect the previous docker installation). I have then followed your notes https://github.com/ladybug-tools/butterfly/wiki/Windows-10-Installation-Notes and butterfly runs without problems.

Thanks a lot for your help anyway!

Dan