Butterfly no wind vector visualized

I tried my best to install, and run open foam and butterfly. And by searching many answers on GitHub, I solved a lot of problems in this process. But I still got a final problem before I get the analysis result. Hope someone can help me out. (I really struggled for it😭)

I used the file uploaded by devang. I use the latest butterfly version 0.0.05.
The screen shot below shows where the problem is. The vectors to come out as (0,0,0) in solution component. no visualization appear of the airflow.

It seems like no vectors are generated. Therefore also no wind visualization occur. Ux, Uv and Uz remains 0 during the loop in OpenFoam. But all the components run in Open Foam without any errors. (I’ve updated all the components to the latest version and match the rhino unit with meter but still don’t work) the same question as the one who got previously but no answer yet.

much appreciated!

Hi @Cathrineding,
Can you please share the GH file? Also, are you using the latest BlueCFD installation orthe old installaton that required docker?

Thank you for your attention!image and I installed open foam from this website https://sourceforge.net/projects/openfoam/
It seems that I can’t upload attachment because I am a new user. I uploaded this file to google drive. This is the link. Sorry to bring inconvenience to you!https://drive.google.com/open?id=1vuU826gjbguIWfbWL3uher8R0CDmJA1e


Hi devang,
I tried to install the latest BlueCFD, and it worked! thankyou! But now I got another problem.

The result of solution component didn’t have “simplefoam” folder(and My computer folder didn’t have it either as shown in the picture), so the plot residuals cannot run. However, the panel connected solution component said it create simple foam folder.

  1. Solution exception:Failed to parse C:\Users\CatherineD\butterfly\Outdoor_Sample\log\simpleFoam.log:
    [Errno 2] Could not find file ‘C:\Users\CatherineD\butterfly\Outdoor_Sample\log\simpleFoam.log’.: C:\Users\CatherineD\butterfly\Outdoor_Sample\log\simpleFoam.log

hi @Cathrineding

I think you need to run your case first for the log to contain residuals’ data.

let us know

Thank you for your attention! Does ‘run case first’ mean run “create BFgeometry” first? I did run it first, then “blockmesh”, “snappyhexmesh” ,“generate testpoint” and finally “solution”. But it didn’t work.

I am facing same kind issues, very simple example mass blocks works.
these are errors appears, I try to reduce mesh count and grid options, I get the same errors.

Not sure how to proceed.

When I increase mesh count, process abort.