Butterfly, OpenFOAM installation problem (Waiting for IP)

installation
#1

Hi,
I have a problem during the installation openfoam in new windows update.
In the powershell window I faced to an error in Waiting for IP error.
Of_v1612plus_centos66.tar image loading . Please Wait....... An error occurred trying to connect: Post http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/images/load?quiet=0: open //./pipe/docker_engine: The system cannot find the file specified.

I install OF 1612+ and 1706 and latest docker toolbox and virtual box.
How can I solve this issue?

Thanks
H

#2

Are you trying this at work? Do you have necessary privileges to access the web?

#3

I am facing the same problem. I try to connect to different network including private (my home) and public (library and office) ones, all failed. The most weird thing is that before last weekend it used to work fine in the networks mentioned above.

#4

Hi @devang,
I don’t have limitation to access the web. and I disabel the antivirus and firewall during the installation.

#5

I do not know if this helps. I just installed OpenFoam 1612+ and faced so many problems. After reading errors, I found out that something is wrong with the virtual box application that is in the default installation. I think, that version has compatibility issues with win 10. What i did, was downloading and installing the latest version of virtual box. While installing docker i unchecked the installation of virtual box. Also i had an issue using my VPN so I suggest to disconnect yours if you have it running. And everything worked fine.
I hope it helps.

1 Like
#6

After Installing Windows again It solved!

OpenFoam Installation error: ssh command error
#7

@daniel.dolatabadi - did you download a VB version >5.2.22 , which is the version mostapha recommends for Windows 10?
Just wanted to clarify, you uninstalled OpenFoam, installed the latest version of VB, and declined the download of VB when downloading docker? Did you need to start the Docker Start Terminal before the OF_Env_Create?

#8

I just installed OpenFoam 1612+ and faced so many problems. I found out that something is wrong with the virtual box application that is in the default installation.

#9

We moved on from OpenFoam for Windows. Download the latest version of Butterfly (0.0.05) from Food4Rhino and follow the installation instruction here: https://github.com/ladybug-tools/butterfly/wiki

#10

As per my opinion you should first check your router settings and take the necessary allowance…and try it from the genuine site…