Butterfly_Snappymesh problem

Hi all,

I have a problem with the Snappy_Hex_Mesh operation. I have setted the Snap imput to FALSE but the mesh doesn’t fit at all the wall boundary and so the results of the simulation are not correct. Anyone have an idea on how to solve this problem? I have attached an image and the GH file.

airflow_internalisedgeo.gh (571.0 KB)

Thanks a lot.

You should set Snap as True. Another setting is increasing surface r

Dear @minggangyin,

Thanks for answering. I solved the problem. I have another question: do you know why the geometries on Rhino disappear meanwhile the simulation on Butterfly is running? It happens on the way, more or less in the middle of the simulation process. I can’t figure it out.