Butterfly TLS connection error



I have been facing with TLS connection error.
Do you have any suggestions for solving it?



I wish I had a simple solution for this. Based on the error it can’t find the default VM. Try to open the VM and start default manually.


Dear Mostapha,

The thing is VM worked out fine. However, there is lot more.

First, i have completed the setups of rhinoceros- grasshopper -butterfly- openFOAM, and currently running them as administrator. The problem is I have been facing with SSH, TLS connection and certs problems (error codes as 125 and 255 most of the time).

Then to solve SSH problem, I have downloaded cygwing and SSH files were downloaded and seemed working fine. However, VM still has problems with SSH.

I tried many many things and obviously need your help. Thanks in advance!

All the best,



I also encountered with same problem. As I search for the problem there are many suggestions but not worked any of it. Will it be helpful if we change Virtual Machine software?


Dear Friends,

The problem is solved and I would like to share it with you hoping it to be a solution in case of any need. Docker machine has a config.json file located in C:\Users\Username.docker\machine\machines\default
The problem in running is due to the docker, which cannot find the host address or trying the wrong address writen in config.json.
The solution is:

  1. Write ‘docker-machine env default’ command via cmd to see what the IP of the host is searching for.
  2. The command will get you to have the following strings:

SET DOCKER_CERT_PATH=C:\Users\Username.docker\machine\machines\default

  1. Then select part of the SET DOCKER_HOST=tcp://, copy it and paste it in HOST bracket in config.json file.

That’s it.
Hope it works for everyone.