Capture view in Grasshopper Black

Hello, why Capture view in Grasshopper is Black? When I True the toggle and save pic in my folder.

Not sure. Is this with the Legacy Ladybug capture view or the LBT Ladybug version?

I use this componant. Capture view. Legacy ladybug

Same problem here, @chris .
In my case I’m using “LB Capture View”, version 1.1.0.

Any suggestions?

Thank you!

Carles

I suggest upgrading to version 1.2.0 of the LBT plugin, @Vance07 , but I sense that this may be an issue on McNeel’s end given that both the Legacy and LBT plugins seem to be affected and there are some similar issues that I see on the Rhino forum:

Do you also get a black image when you use the ViewCaptureToFile command within Rhino? If so, then we can be fairly confident the issue is on McNeel’s end. If not, then maybe there are some things that we could try in the Ladybug Tools source code.

CC: @wim , @piac

Yes, ViewCaptureToFile with Rhino get a black image.

Hi -

Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino 6 SR31 2020-11-10 (Rhino 6, 6.31.20315.17001, Git hash:master @ ff08c426b1ef7d3a1c50a01e5e87220a68a9f815)
License type: Commercial, build 2020-11-10
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 3.9Gb)
Machine name: DESKTOP-GCQALV4

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics 3000 (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y). OpenGL Ver: 1.1.0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 5-19-2016
Driver Version: 9.17.10.4459
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1842774 KB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi - Thanks for that information.

This part shows that Windows is not using the GPU. I took a look at the Intel site for updated drivers for the HD Graphics 3000 and see that there are no drivers available for Windows 10.
That means your machine can’t be used to run Rhino 6 reliably.
-wim

Thanks @wim for your help

Thanks @chris for your help.

Thanks you all for your help !!!

Carles