Changing surface type


#1

hello!
Creating a model in honeybee I’ve got some problems with the ground. I created a box, exploded the Brep, set the surface type with the creating honeybee surface component -4 walls, 1 floor, 1 roof- and then unify all in the create honeybee zone component. Finally, I used create EP Ground. The problem is that when I read the idf file the surface I set as roof is calculated as a ceiling, so it’s not sun and wind exposed…why? What can I do?


#2

The first thing you can do is to upload your file so we can try to help more efficiently.
Otherwise, it is hard to say.
-A.


#3

Thank you for your answer Abraham!
Sorry, I didn’t think about it…this is the file.I have the same problem for the surface named ‘littleground’ too. I want it to be floor exposed, but it is analysed as a normal floor.

GroundRectangle.gh (938.9 KB)


#4

I suggest to try and simplify your model. (For me) it is hard to check something in your file. Bring it to the minimum you can so the problem shows.
Sorry …
-A.


#5

Don’t worry, I understand. I’ll try to semplify it and if I obtain a good result but I still have problems, I’ll upload the semplified file here. Thank you for your availibility, Abraham :slightly_smiling_face:


#6

Hi Abraham, I’m sorry to disturb you again. Following your advice, I’m trying to obtain an exterior floor using a new very simple file with just a plan in it. Even here, I have the same problem. I tried to rotate the plan, to change its normal, to set ‘exterior floor’ from EP library, to set the boundary conditions…but I only obtain basic structures: a wall, a roof or a floor (interior). I think that I’m doing something wrong. Can you tell me how can I set all the other types of surface in general? I upload the example file I’m using.
example.gh (462.2 KB)


#7

Check the attached.
I started from a box and created a thermal zone. Then i decomposed it and changed the properties of each surface. Then i reunited them again in a thermal zone.
There are 2 groups. In the yellow one you can check the properties of each surface as the default box stage. In the blue one you can check after the change.
Is this what you want to do? You can simulate it and check the idf for the surfaces properties. It should work.
I’m not sure if i’m going to basic with this example. Sorry if i do. In any case this is one of the ways to do this.

-A.
example_AY.gh (495.8 KB)


#8

Sorry for the late answer, Abraham, I was trying to find out the mistake thanks to your help. Yes, this is what I wanted to do. I used the same method, but I didn’t know how to check my work with the labelsurfaces component. Thanks to this, I think I have found my mistake and it is not in setting the surfaces, but probably in the honeybee zones I created. I’m still not sure about this, but it’s a good point to start. Thank you so much!!