Comfort map error: OpenStudio executable is not accessible

Hi all,

I have an issue running the Adaptive comfort map. It has this error: Solution exception: An OpenStudio installation was found at C:\openstudio-2.9.1\bin\openstudio.exe but the OpenStudio executable is not accessible.

Would be great if anyone could help me with this issue.


Hi @chris,
Do you have any idea why I get this error? I tried it on another system with OS 2.5, but got the same error.

The LBT 1.4 plugin works exclusively with OpenStudio 3.3 as you see in the compatibility matrix.

So I would first recommend installing that. If you still get this problem after installing OpenStudio 3.3, then the real error should be coming immediately after that message in your screenshot.

1 Like

Thanks @chris for the help. Upgrading version solved the issue. Now, I have another issue in the next step which am not sure what raises it.

The point is when I ran it on another system it worked well but would be great to know the reason for it.

On the other system though, I have this error that do not know how to solve it.

Could you please help me to understand these issues?

Thanks (700.5 KB)
I also upload the script here.

Hey @masoome ,

There was a bug in the last release when you tried to run the comfort maps for shortrun periods. Removing the run period or upgrading to the latest development version of the plugin with the LB Versioner should fix this. More info here:

Also, don’t mix Legacy and LB components in the same script:

Use the equivalent LBT component

1 Like