Confused about Cooling Energy when Using Operable Windows?

Hi all,

I wonder if someone might be able to explain to me what I’m seeing here or let me know where I am going wrong? If I:

  1. Model a super-duper simple room for just a single week in August

  2. Set it to Ideal Air Loads, don’t set anything else.

  3. Simulate it, check out the results, all seems ok.

  4. Now go in and add some operable windows to it, give them a reasonably modest (I think?) operation rate

then my ‘cooling’ energy result goes all funny. I think it seems to be including the effect of the window ventilation as ‘cooling’ energy? (Maybe? I Dunno…) If I do two simulations:

one WITHOUT operable windows, and then one WITH operable windows, I see Total Cooling Energy results that look like:

The red is Cooling Energy without operable windows, then the blue is the Cooling Energy once I add in the operable windows?

So I suppose my question is: is it possible to disaggregate the window cooling from the ‘regular’ cooling energy? If I want to know Ideal Air Loads Cooling Demand Energy from a mechanical system, is that possible once I add in the operable windows? Or are they always gonna be all mixed up together? Is there an output variable I can add to see this? Or am I doing something wrong with my operable window setup that is causing this?

If anyone has any ideas where I’m going wrong - I would of course really appreciate it.
Example .GH file attached here if you are interested or have any thoughts.

thanks so much!
@edpmay (87.3 KB)

1 Like

I’m fairly sure the default max ODA-T == Culprit

When ran with max ODA-T @ 22:

I wonder if there’s a way sans wash/rinse/repeat: to get a bit ‘dynamic’ with the wndw op _schedule / ΔT IDA/ODA or something to ‘optimize’. erring on the edge of ‘too dynamic may deviate from truth more than less so’.

Thanks @TrevorFedyna !

Interesting. I think though - if you reduce that ODA Max Temp, you effectively cancel out / turn off the window ventilation right? So you end up back with a ‘non-window-ventilated’ space right?

the blue line (effectively 0) is the revised Window Energy @ 22C ODA Max Temp, the red is with it set to 100C:

Ideally I’d be able to keep windows as operable, but also be able to see just the mech cooling energy, no?


1 Like

AAAHHHHH. yeah; that makes sense!


Your cooling energy is just really high with operable windows because the warm outdoor air is higher then your cooling setpoint (24 C during occupied hours). You always want your cooling setpoints to be above the natural ventilation setpoints for this reason.

You can get passive cooling energy reduction by setting your max outdoor temperature or max indoor temperature under your cooling setpoint. The rule of thumb is NV setpoints should be 2 C less then cooling setpoint, and 2 C higher then heating setpoint. Ideally you also want to increase your cooling setpoint.

1 Like

@edpmay, the valid straightforward answer is what @SaeranVasanthakumar suggests, as you need to avoid concurrent natural ventilation when estimating cooling demand. But, I would say one way of seeing the positive potential of extra natural ventilation is to enable the air economizer in your ideal loads air system, so that it introduces extra outdoor air through the mechanical systsem when it helps reducing the demand.

@farhang.tahmasebi excellent point.

This brings up a question that I’ve had for a while (for anyone to answer):

Is there any advantage (outside of small fan power reduction) in using natural ventilation in a mixed mode building with an economizer - in terms of thermal comfort standards? For example, could choosing natural ventilation over the economizer allow you to use an adaptive thermal comfort standard during those periods, and therefore allow longer periods of passive cooling?

The ability to use the adaptive thermal comfort standard seems to offer an obvious advantage in buildings without mechanical cooling, but I can’t tell if this translates to mixed-mode buildings.

Hi @SaeranVasanthakumar, @farhang.tahmasebi

Thanks so much! Thats really helpful - appreciate the input.

I think I still don’t quite fully understand though? If I do something like adjust my set points to 25C (cooling) and 20C (heating) and my VentControl ‘min_in_temp’ to 22C (as you say: set it under my cooling setpoint, right?)

I get similar very large cooling energy reported, except now it spikes overnight instead of during the day?

I still don’t understand, conceptually whats happening here? In a representative day I see:

The daytime part makes sense to me: outdoor air is > indoor setpoint (25), so cooling is ‘on’, indoor temp is running at the setpoint. That all makes sense I think.

And then overnight, the outdoor air is below the cooling setpoint, and so is the indoor air temp, but it makes sense that I’d see overnight windows open since I have the VentControl ‘max_in_temp_’ set to 22, so until its 22 inside, the windows should stay open (right?)

The part thats confusing to me is that the cooling energy shows up really, really high overnight even though the indoor air temp is well below the cooling setpoint, as is the outdoor air temp? I don’t understand why that would be? Or am I misunderstanding what ‘Zone Idea Loads Zone Total Cooling Energy’ means?

Can you spot where I’m going wrong here with my setup?

  • Cooling setpoint=25
  • Heating setpoint=20
  • Windows Open until its 22 inside (VentControl min_in_temp_=22)
  • Operable windows with a _fract_area_oper=0.25, _fact_height_oper=1, _discharg_coeff=0.45

any thoughts are appreciated. GH model attached as well.
@edpmay (118.3 KB)


You need to tell your windows to close before your mechanical cooling is triggered by its 25C setpoint. So set your max_out_temp to 24, so that the mechanical cooling isn’t trying to cool a space while hot outdoor air is coming in through your windows.

Hey @SaeranVasanthakumar

Interesting - thanks for the suggestion. That doesn’t seem to do it for me though? I still see surprisingly (I think?) high ‘cooling energy’ overnight even when I set the ‘max_out_temp’ to 24:

It seems the ‘Cooling Energy’ is showing overnight up when the outdoor air is below the interior cooling setpoint?


Interesting, I’m not able to reproduce these spikes on my computer, but I’m also stuck with LB 1.1.0 so haven’t been able to run your script as is.

At any rate, I think this might be the issue:


This input requires a numerical input, so plugging in a False means that the value is actually being cast to a 0. So your cooling system is now trying to maintain a 0% relative humidity. If you remove the False, the default assumption is that there’s no humidity control, which is what I think you want.

ah! I think that you are exactly right - thanks so much @SaeranVasanthakumar - when I turn that humidity control ‘off’ my cooling energy seems much more as I’d have expected:

I think that must have been it: so I was trying to dehumidify down to 0% RH all night with the windows wide open?.. right… that totally makes sense then.

thanks so much!!

1 Like

This discussion reminded me one in the old grassohpeer forum. See here.
It is more intended for a more mixed mode (towards passive, because of the setpoints).
Maybe you can find it useful, as i do.

1 Like

Thanks @AbrahamYezioro it is useful.

It’s worth highlighting one point that Chris makes in that discussion, that I didn’t bring up here was that the minimum outdoor air can be a lot cooler then your cooling setpoint. So, my rule of thumb is: we should keep the indoor NV setpoints 1 to 2 setpoints inside the heating/cooling setpoints, but set the minimum outdoor air lower then the cooling setpoint.

Determining that minimum outdoor air is really a function of your buildings internal gains, so I think calculating that with the building/zone balance point is a good way to approximate it.

1 Like