Daylight analysis - index out of range & frozen/stuck cmd


First-off, thank you for all the work you’ve put into this! HB&LB are amazing plug-ins :slight_smile:

Now for the problem:

I’ve been working on some energy and daylight models. I have run the same model a couple of days back and it worked perfectly, but now it just will not run (completely). There are no problems with the energy part - except that sometimes the material is not loaded into the library on the first run.

For daylighting however, I’m getting multiple errors:

  1. Solution exception:index out of range: 0 When I connect a panel, it says it traces back to line 320.

  2. What’s also new is that the cmd gets stuck. Almost like it pauses, while previously the daylight simulation would run in seconds.

I’ve updated the components with the update component, and I have also ran the batch files after adding ‘pause’ to the files, but not much happened there either.

Hope you can help me, thanks for your time :slight_smile:

Anne (720 KB) (5.83 KB)


Would be helpful to attach also the geometry …


test geometry in attachment

testmodel v01.3dm (78.1 KB)

OK Anne.

I’ve found a bug which is causing your file not to find the results. Also, even though you updated using the update component, there is one that needed to be reinserted (reColorMesh, see red group for the old and white for the new).

The bug is that the analysisType output of the LookupFolder_Daylighting component is giving an extra line with a “%” in it, while the same output from the runDaylightAnalysis is giving only one line. You can see in the yellow group the one conected to the right output and the one with the bad one.

This is a bug to report so Mostapha can fix it easily and quickly.

I disconnected some of the Radparameters to save time, so you probably will connect them back.

-A. (734 KB)

Thank you Abraham! :smiley:

That was a decision that I made to save the component from one extra output but I can see how it can be confusing. Updated1


I get the same error.

Any suggestions how to fix it?

Here are the files (4.45 MB)

Hi Havard, Your file runs with no issues. I wonder if this is a similar issue to this one:…