Daylight Simulation Error.log

Hi Community

Before updating the latest versions of HB/LB today everything was fine , but now I got an error regarding daylight simulation which I dont understand why … as it says it can not find error.log which should be a text file as far as I know, and it actually doesnt exist … I have already updated the plugins, tried different file name and working directory … but still it doesnt work for Grid & Image based simulations however It works for annual simulation …

Thanks in advance

Dear @chris & @mostapha,

I have uninstalled the latest Radiance version (5.1.0) and Installed older version 4.2.2 and it works fine !

Is there any possibility that HB is not compatible with the latest version of Radiance ?

Honeybee works with the latest version of Radiance with no issues. This error happens when your simulation crashes before ray-tracing. It’s a result of having an invalid input for sky or materials. Try to run init.bat file after adding a pause at the end of the file and you should be able to see the error message.

Hi Mostapha - I’m getting this same error when I try to run Daylight Factor (although annual sim works fine). I don’t understand how to implement what you are suggesting with init.bat (what is that?) and adding a pause - can you please elaborate?

hi @PriyaGandhi he is basically saying go to the project folder ( the one where your results are being gathered) and right click on the commands.bat file and open with a text editor. Write the word “pause” at the bottom of the text file. then do a save overwrite. Once you do that double click on the commands.bat file. That will rerun the file and list the error message with out closing the prompt.

1 Like

@FabianPosadas thanks! Now I have a new error to figure out how to solve, but hopefully that’s one step closer to getting it to work!

1 Like

My problem solved by installing Radiance 5.0.1 version Win32 … Thanks Everyone

@AMIRTABADKANI @mostapha I am having the same problem described in this thread and the solution is not working for me… I cannot get radiance to run with a point-in-time simulation. I’m using the example file for the glare analysis. I’ve uninstalled radiance and reinstalled everything from the newest version to the older version 4.2.2 and ones in between. The error message I’m getting is “‘rpict’ is not recognized as an internal or external command, operable program or batch file”. I get the same error message for every radiance command that is attempted: oconv, rpict, pfilt, etc. I have no trouble with the annual analysis. Any suggestions appreciated I’m struggling to figure out what is going on. I also have DIVA installed on this machine - not sure if that is interfering?

I figured out the problem. For me, Radiance must be installed to C:\Radiance - NOT C:\Program Files\Radiance or C:\Program Files (x86)\Radiance. Older versions of Radiance default to C:\Program Files\Radiance and the newest version defaults to C:\Program Files (x86)\Radiance. Solved!


excuse me, i am using ladybug 0068 and honeybee 0065 and have this same error. i have reinstalled radiance from different version and put it in C:/radiance but it still does not work. i do not really understand about the .bat file and how it works. could anyone give me some advice? thank you

Please followthis link Legacy Ladybug 0.0.69 / Honeybee 0.0.66 and Honeybee[+] 0.0.06 Release and update your Ladybug tool. Than try again.

Thank you so much! it works now

I added the “pause” in the .bat file per the above recommendations…i can then extract the error:

“This program is blocked by group policy.”

full output…
C:\ladybug\unnamed\gridBasedSimulation>SET RAYPATH=.;C:\Radiance\lib



C:\ladybug\unnamed\gridBasedSimulation>cd c:\ladybug\unnamed\gridBasedSimulation\

C:\ladybug\unnamed\gridBasedSimulation>oconv -r 2048 -f c:/ladybug/unnamed/gridBasedSimulation//material_unnamed.rad c:/ladybug/unnamed/gridBasedSimulation/ c:/ladybug/unnamed/gridBasedSimulation/unnamed.rad 1>unnamed_RAD.oct
This program is blocked by group policy. For more information, contact your system administrator.
oconv: warning - (!gendaylit 6 21 9.0 -a 39.87 -o 75.230000000000004 -m 75.0 -W 392.13793103448273 210.41379310344828 -O 0 | xform -rz 0.0): empty file
oconv: fatal - (c:/ladybug/unnamed/gridBasedSimulation/ undefined modifier “skyfunc”

so what program is blocked in this instance??