Dctimestep taking too long

Hi folks,

I am running an annual daylight study using honeybee+. It is taking too long and my computer says dctimestep is running. Is it possible to run dctimestep in parallel? I have access to a linux workstation could dctimestep be run on that computer? if yes, can anyone share a guide on how to save the file and open/ run it on a linux system?

Thank you

Someone had asked this question on the Radiance mailing list a while ago. You can find my reply here:


Are you running an image-based simulation?


Thank you for helping me on this.

No, I am only running a grid based daylight simulation in Honeybee[+] with HoneybeePlus_Run Radiance Analysis component.

Unfortunately that was the only component which, although iffy, would read data from about 900 points. I tried the three point and five point components, they would write the ILL files but would throw an error when reading them.

The HoneybeePlus_Run Radiance Analysis component also would throw a read error if I tried to push slightly more points. It was very finicky. Maybe I need to split the floor plan into parts to run the annual daylight analysis.

Thank you,

This is a known issue

This is known issue and why we’re implementing a database to Honeybee[+]. You can read more here under upcoming release: Honeybee[+] 0.0.04 for Grasshopper, Ladybug 0.2.0 and Honeybee 0.1.7 for Dynamo Release

and here:

1 Like

Hi, i was wondering if this solution had been implemented in the latest honeybee and ladybug packages for dynamo?
i am currently running solar analysis, and the DCTimestep is taking quite a while. I have seen that it might be possible to run the DCTimestep in parallel,is there an example of how to update the dynamo nodes to do this?