Design explorer upload issue


Ive ran Colibri iterations and have the “data.csv” file plus all the images on my with a public access. Hers is the link to it:

But when I try to upload the link in design explorer through “get data” tab, nothing shows up. meaning that it doesnt upload anything without displaying any error message or so… Anyone has an idea what might be the issue? @mostapha

Highly appreciate your help in advance,

You’re using the wrong link. You should use the link to the exact folder like this one:

Here is the results loaded to DesignExplorer:

1 Like

Thanks a lot for the reply @mostapha

Just one more question for this test run. In order to have a 3d model with the daylight simulation visible, how should I save the results to get it on design explorer? atm it only shows all the .png files as 2d -which makes sense- and the preview of the model in shaded mode (how can i change that?) without the daylight simulation.

all the best,

Design Explorer has an input for 3DObjects. See this sample file.

1 Like

I have actually tried to input wireframe curves (brep wireframe from HBsurfaces), together with the analysis mesh, to aggregate’s 3D-object. But the problem is that I get the error message “1. Solution exception:Object reference not set to an instance of an object.” from the aggregator. The list of inputs is flattened and nothing is running “null”. This is while if I input the HBsurfaces directly as 3d input geometries, aggregator runs fine. Is this a common issue?

This issue should be posted to TTToolbox forum unless @MingboPeng can help you with this question here.

1 Like

Could you internalize the curves and mesh, and just send me the grasshopper file with these two geometries? (657.1 KB)

Please find the file attached. And many thanks for the support.


Design Explore doesn’t support the curves, please convert it to polyline first.

hello dear
I ran the colibri iterations and have “data.csv”, but in this folder that I saved my data; there is just one image. however, it is running. Are there any problems?

Hi @MingboPeng ,
Ive used colibri 3D-object and I have the json files, but it seems design explorer doesn’t load 3D files. I can’t rotate in 3D mode and it is like an image.
Is there any problem I didn’t pay attention to ?
I use polyline in spite of lines.

here is the linke

Hi @Hanie I don’t see any major issues with your model. It seems all files are loaded correctly. But by any chance that your model is located far away from the origin? If yes, you should move it to somewhere near or on top of the origin (0,0,0).