DF simulation not running


Some students in my class want to run daylight simulations for their project. I prepared a relatively simple script, which I tested before sending it to the students. However, one student was unable to run simulations with Radiance. When she starts the simulation, the ‘Command Prompt’ appears for 1 second and then disappears, generating no calculations or results. We have uninstalled and reinstalled all the software, but without success. I retested the same script on my computer, and everything works. Do you any ideas as to why it does not work?

Here is the script, and a screenshot of the window that appears, right before it disappears.

Thank you very much for your help!

Simulations-FLJ-et-annuelle_AC.gh (139.0 KB)

Hi @Alexcarrier30,

The file needs the installation of other plugins and the geometry is not internalized. Without that, no one will be able to help. Please also check these guidelines to get started on the forum.

I’m sorry about that. This should work as I have deleted the components from other plugins.
Thanks again!

Simulations_DF_AlexCarrier.gh (87.1 KB)

Thank you for the file. I ran it at my end and it works just fine. I now observe that there a empty space in the user name of the student and that might be the reason for this failure. It might help to try instructions mentioned here

There is an input to get the logs for the run. My best guess is that the student is using an older version of the Radiance installation.

I believe we are handling cases with white space. @chris, is that correct?

@mostapha ,

We are taking care of the white space when we call the queenbee-luigi command because we are running it with subprocess, which automatically puts all of the strings in quotes.

However, I can see that the queenbee commands of the recipe might not be putting the paths in quotes as I was able to recreate the issue just by setting the “Run Recipe” component to write to a folder with a white space:

annual_daylight_quenbee_error.gh (59.7 KB)

Let me know if you think you’ll be able to fix this in the near future, @mostapha . If not, I can open an issue on the “garden” repo we have that hosts the recipes. Or I can open one on honeybee-radiance-recipe if you think we should only fix it there for now.

Also, I would assign this topic to you, @mostapha , but I think you are currently maxed out in the number of issues I can assign to you.

Hmm… Do you have a reference for this? I’m not sure if subprocess has such built-in feature.

The error is not related to the recipe. It happens before it gets to the recipe and when it tries to parse the input arguments. It should probably be handled here:

By putting the input values in " " before passing them to subprocess.Popen.

@mostapha ,
It’s definitely an issue somewhere in queenbee-luigi, though maybe my explanation is not correct.

I tried the following edit to manually add the "" to the _folder_:


But doing this results in the following error:

Usage: queenbee luigi translate [OPTIONS] RECIPE [PROJECT_FOLDER]
Try 'queenbee luigi translate --help' for help.

Error: Invalid value for '[PROJECT_FOLDER]': Directory '"C:\Users\chris\Desktop\Test Folder"' does not exist.

I get this error whether or not I pass the command argument in as a literal string or I escape each double quote.

So trying to pass in arguments as a sequence to subprocess but with double quotes around an argument clearly results in duplicated double-quotes (I am guessing that there’s one pair of quotes that subprocess puts there and another that I am putting there manually). It may also help to know that the commands I call with subprocess for energy result parsing are able to handle the white space in file paths without any extra double quotes but I get the same error about duplicated double quotes if I try to manually add the double quotes. So it really seems like the "" are automatically included when using list inputs for subprocess.

If you want, I can forego this use of a list input for the arguments for subprocess and just format the whole command as a single string. In that case, I can manually add the quotations where they are needed and everything works. But there’s definitely a bug here in the way that queebee is parsing the arguments since it is currently incompatible with subprocess list inputs at the moment. So let me know how you’d like to proceed.

This has to do with how shell parses the input values. I’m updating queenbee-luigi to work with the new queenbee schema and will have a look into a better solution to handle this.

1 Like

Hi All,

I am trying to develop a Daylight factor calculation and checking the sample file you included in the last version of LB+HB (after installing radiation and openstudio) the window of the queenbee opens when I set true in the toggle to RunRecipe but it closes without giving any result of the analysis.

I am reading in the blog and apparently is this same issue, I have changed the name of my user in the computer and still the same, and I have done it in another computer and there worked well

Do you have any idea what could be happening?

I thought I had changed the name, but the folder was still named with the space, once I managed to change it ( https://www.youtube.com/watch?v=w5N2aaiToiQ ) it worked well.