DLL Errors installing on Windows 11?

Hi everyone,

I wonder if anyone might have any insight or suggestions on some installation errors I’m getting using Windows 11 on a Macbook/Parallels?

I’ve used OS and E+ / HB on my Macbook with Windows 10/Parallels for years and all worked great. I am trying to move to a new M1 with Windows 11 and running into some install errors now though? I wonder if anyone has any insight?

If I try and install E+ 9.6 on its own just gives me straight error and crashes without installing:
“The code execution cannot proceed because MSVCP140.dll was not found. Reinstalling the program may fix this problem”"

OpenStudio App 3.3 and OpenStudio 1.3 install ok, but then if I try and open/run OpenStudio App I immediately get the error “Measure Manager has crashed, attempting to restart… unexpected ucrtbase.dll” and it freezes up

LBT 1.4 installs just fine, and everything runs except if I try and execute an OS write, in that case I get another version of that DLL error:

@TrevorFedyna helpfully suggested using the srf /scannow routine as outlined here link, and I also reinstalled Direct X, as suggested. But none of that seemed to do the trick and I still get the same errors. I’ve reinstalled a few times, to no success just yet. Is it just that E+ / OS don’t support Windows 11 yet? Some other conflict or thing I haven’t installed properly?

I wonder if anyone has run into similar issues or has any suggestions on where to look for some solutions? I appreciate any input or suggestions!

For reference, trying to install on:

  • Macbook M1, OS 12.2 Monterey (all OS updates done)
  • Parallels v17
  • Windows 11 (all OS updates done)

thanks for any help on this if anyone has any thoughts! FYI, I have also posted this to Unmethours to see if anyone there might now the solution?

can you perhaps take a look at the event log ? maybe get a weee bit more detail, ucrtbase is the C envi runtime somthing or other dll… (can’t remember exactly)
So maybe there’s a callout of some other dll or mention of in the logs that can be rectified; that’s not getting called out by OS’s error message.

and or:
I’d take a look at ucrtbase with regsvr32, that’s kinda my usual… shotgun troubleshooting… scannow and regsvr32 lol :sweat_smile:

thanks @TrevorFedyna !!
Appreciate the input. None of that seems to help though (unless I’m doing it wrong)

The .dll does seem to be in the OS and OS-App folders, but it still gives me errors if I try regsvr32

thanks though! I’ll keep trying…

This is definitely a question for the Unmethours community so I’m linking to your post over there, @edpmay .

It looks like one of the E+ developers who has helped me out a lot in the past has already posted a suggestion worth trying.

Hi @Chris,

Yes, the fix suggested there (Installing the Visual C++ library) resolved the E+ install issue, so that’s great. The OSApp still isn’t working, but I’ve cross posted the problem on the OSApp Github Issues page and I will post any solutions here as well if we find any.


1 Like

May 5, 2022 Update: For anyone who comes upon this post who is having similar issues trying to run Honeybee-Energy (OS) on a Mac M1 on the windows side:

It appears that as of right now, there is no OS-App compatible with Windows on ARM64. The developers are aware of the issue, and considering how to build out support. But for the time being: Honeybee-Energy export to OS cannot be used on Windows-11 running on a Mac M1.

The Mac-side installation of Honeybee-Energy, OS and OS-App do appear to be working well on Mac M1, however. But that does mean no IronBug, as far as I know.

Just FYI.

1 Like