Dragonfly and ENVI-met LITE domain area issue

Hi @AntonelloDiNunzio,

I thought you might be the one that can answer this issue

I made a ENVI-met model in dragonfly with base area of 45x45 with 25 vertical grid cells. I run the simulation but it failed and the display told me that ENVI-met basic version (LITE) cannot run the simulation more than 50 x 50 x 25. I have checked the INX. File (Space) via grasshopper and it’s clear that my model doesn’t exceed 50x50x25 even in space.

Then I did small experiment by changing the base surface to 44x44 and 42x42 but they also didn’t work with the same reason. But then, when I change to 40X40, it works!
Interestingly, I manually made a model in space (without grasshopper) with domain area 50X50x25 and create SimConfig file inputting this INX (Space). When I run this ENVI-met model, it works!

I don’t know whether someone here found the same issue with me. But, looks like there is an inconsistency of how dragonfly works or connect to ENVI-met.

Could you please give me any explanation or solution to solve this issue?

Cheers,

Wendy

Hi @sunarywend,

Limit of current version should be 50x50x40. Please, make sure you have latest version of dragonfly-legacy and ENVI_MET.

Could you share this example file?

Maybe problem is related to nesting grids. I have added 3 nestring grids by default, but I need to check.

Thanks,
Antonello

ENVI-MET WENDY.gh (494.9 KB)

Thanks @AntonelloDiNunziofor your fast response! I attached the file above
I have provided two base surface that you can change and test separately

Besides, there is another issue:
I have run my ENVI-met model via dragonfly, and it appears that the simulation is in Command Prompt display (figure below). Is it actually like this?

I have tested the previous version of beta DF (last year), and it didn’t show up the command prompt display like that. Instead, it can pop out ENVI-met machine as usual.

The problem with command prompt display is that I cannot notice the ENVI-met time process in simulation (real-time process). So, I dont know whether the machine is actually working. I have tested running the simulation with the newest DF version using the model I attached, but looks like the command prompt display stuck, which at some point doest continue the simulation. Please give me explanation about this and tell me if I did wrong.

Cheers,

Wendy

Hi @sunarywend,

I have checked your file. Code is Ok.
The first grid is 49 x 49.


You can have a confirmation opening INX file with a text editor:
image
The second grid is 45 x 45.

By text editor:
image
You should count also 3 nesting grids added by default.

Component executes envimet console. You have pros and cons with it.

pros points:

  • your computer will be not stuck
  • you can run more than one simulation comtemporarely.

cons points:

  • Software developers of envimet decided to do not add estimation time and other useful debugger functionalities.
    You can continue using Envimet UI to run simulation, it is up to you in what way run simulation. If you find some issue, please let me know.

Anyway, I have been writing a new version to improve integration with ShrimpGIS and Gismo. I have applyed some concepts of Envimet INX for Sketchup.
You will have a better control of grid with it, it will be possible to generate bigger grids and other improvements.

Thanks for your feedback,
Antonello

Thanks @AntonelloDiNunzio

To be honest it still seems odd to me because I coudnt run that 49x49 (that you checked). I also have checked it in SPACE, which shows me 45x45 instead of 49x49. This means that I must anticipate my model in Grasshopper by making sure the base surface is smaller by 10 cells.

I have run ENVI-met simulation via grasshopper with cmd display and it totally works!

For the integration with ShrimpGIS and Gismo as well as INX for SketchUp, can you please give me the related link?

Once again, Thanks for your support

Regards,

Wendy

Hi @sunarywend,

Text editor shows what Envimet Spaces will read.
In your example one grid was 45x45 and the other one 49x49, however, you need to add 3 addictional nesting grids in XY plane (left, right, up, down) that are setted by default, so 45+6 in the first case and 49+6 in second case.

This is something that you do not need to take care in next realease, grid settings will be easier.

In the meantime, I suggest you:

  1. use this version: df envimet components
  2. use viewGrid_ input of DF Envimet Spaces
  3. set nesting grid to 0
    image

You can already use buildings that come from Gismo or ShrimpGIS as geometry input with current version.
Example with version at point 1.
00_shrimpgis_dragonfly.zip (411.1 KB)

Best,
Antonello

1 Like