Dragonfly components installation

Hi @AntonelloDiNunzio,

I’ve created this new topic for the issue.

I have tried the manual installation;

  • copy and paste “uwg” folder here: C:\Users%USERNAME%\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\
  • drag and drop all components of “userObjects” into grasshopper canvas
  • copy and paste “envimet” folder into C:\Users%USERNAME%\AppData\Roaming\Grasshopper\Libraries

I end up having only part of the Dragonfly components, see attached image.

Many thanks,

@mk-1 You can download the latest verison of dragonfly envi-met Here is the link created by @AntonelloDiNunzio

Thanks @minggangyin

I’ve tried installing it via that link before with the same result. I do however get an error if I try to unblock the zip file (this is the same error as before @AntonelloDiNunzio).

If I click ignore the following components are present in the file;

Can this be the problem?

Hi @mk-1,

this is a windows issue. Could you:

  • remove check “read-only”
  • click on unblock
  • click apply and Ok
  • extract folder where you want in your machine
  • copy and paste df_envimet and df_envimet_lib.dll in C:\Users%USERNAME%\AppData\Roaming\Grasshopper\Libraries. I suggest you put them in a subfolder to have some order in Libraries folder of Grasshopper
  • close Rhino and Grasshopper
  • run Rhino and Grasshopper session to see if components are there

Regards,
Antonello

Dear @AntonelloDiNunzio,

It is working, I have all components now.

Thanks a lot and stay safe,

Regards

Dear @AntonelloDiNunzio,

It seems like there is still a component missing; DF visualise buildings. I want to use it for adding facade greening. If tried installing both beta version as the ‘normal’ one from Github.

See image below.

Thanks in advance!

Hi @mk-1,

you can use ‘DF Read Facade’ that shows you how buildings are made in ENVI-Met and a new component that I have added to beta version today.
It works by selecting particular rhino meshes baked by ‘DF Read Facade’:


Example_beta_select_facade.gh (389.4 KB)

Regards,
Antonello

Dear @AntonelloDiNunzio,

Thanks a lot for your reply and this update. There is one thing I dont understand, how can you use the baked facade from DF Read Facade as input in the ‘DF Edit Facade Material’ component? Sorry if I misunderstood you.

Regards,
Milou

Hi @mk-1,

It is an uncommon grasshopper component. I have added a short tutorial: New features
You should hold the selection in Rhino and then set ‘runIt’ to True. Component reads Rhino selection in real-time.

Please, let me know if it is clear, otherwhise it is better to open a new discussion about it.

Regards,
Antonello

Dear @AntonelloDiNunzio,

Perfect it works.

Kind regards,
Milou