Dragonfly issue with UWG component

Hi All, hi Chris,

I’m trying to investigate with your latest tool “Dragonfly”.

After some re-installation procedure i have this error with UWG component, this is the error message (readMe! out):

0. Current working directory is set to: D:\Documenti\Documenti Luciano\Dottorato PC\RESEARCH\Urban_Weather_Generator_Workflow\UWG definition\EPW_Morphed\unnamed\UWG<br/>1. Runtime error (FileNotFoundException): Impossibile trovare il file ‘D:\Documenti\Documenti Luciano\Dottorato PC\RESEARCH\Urban_Weather_Generator_Workflow\UWG definition\EPW_Morphed\unnamed\UWG\unnamed_USA_FL_Miami.Intl.AP.722020_TMY3.epw’.
2. Traceback:
line 232, in reOrderEPWData, “<string>”
line 382, in main, “<string>”
line 410, in script

I’ve checked in UWG directory and i saw that epw file (morphed) is empty 0kb, it’s the only empty file (.bat 1kb , xml 18kb). maybe the issue is simpler than it looks.

I hope I was clear. Could you help me? Thanks for your effort&support.

Hi Luciano, Just a wild guess from the error message. Try to generate the file in a different path with no white space. I think ‘\Dottorato PC’ is the source of the error.

Thank you for your quickly reply, but nothing, even without any path. I gave a look (too fast) at prompt cmd.exe window before this kind of issue, i took a screenshot;

There is still a white space between ‘documenti luciano’. You need to either put the address in “” or use path with no white space.

Yes, my fault this screenshot is before your advice. Then i tried to remove every blank/white space.

Hi Luciano,

It is clear that the correct xml file is being written but it is not being successfully run through the UWG.

  1. Can you upload your GH file to see if I can replicate the error on my machine?

  2. Can you check to be sure that you have installed the latest UWG from this link (https://github.com/hansukyang/UWG_Matlab/blob/master/UWGEngine/for_…) and that you have the following folder on your machine (C:\Program Files\MATLAB\MATLAB Runtime\v90)?

  3. Can you verify that you have a C:\ladybug\UWG folder on your machine?

With all of this, we will hopefully get to the bottom of this.


Hi Chris,

Thanks for your reply. I’ve checked your list: after re-installed Dragonfly, I run MyAppInstaller_web.exe (it installed UWGengine v2.2 + MCR v9).

From your link (it seems to be the same of readMe! message of DF, before to install UWGengine + MCR v9) i noticed that MCR version is 2.11, so i’ve unistalled my previous version (UWG v2.2) then installed that one from your link.

So I saw that from your point 3) in my ladybug directory there isn’t UWG folder, so i copied from https://github.com/hansukyang/UWG_Matlab/commit/f9e7ecb46a1a294dfcf… UWG.zip and I moved UWG folder to c:\ladybug.

Maybe i forget something, so attached my def (that’s original one) i suppose that issue is in my machine (programs).

P.S.: I have the same issue even without specify a new EPW (morphed) path, so I’ve deleted that one in my attached def.

here you are.

Urban_Weather_Generator_Workflow_v2.gh (1.12 MB)

thanks anyway, but magically after launching this definition on another PC, and after again on mine it has worked!

I would like to ask you some advice about the documents/research consulted to develop Dragonfly/UWG, because I’d like to be able to produce some results with these tools (yours and LB+HB team work) to define the search scope of my doctoral thesis (tips in the direction of the Environmental design are always welcome :slight_smile: ), always thanks for your support and your work!

P.S .: I hope that the problem does not happen again, I’ll stay tuned with all the updates about dragonfly + UWG

Urban_Weather_Generator_Workflow_v2.gh (1.12 MB)

P.P.S: I took this two screenshots while UWG running, and i wonder if it’s a good thing.


Glad that you were able to get it working. My guess is that it had something to do with the last thing you did (download the UWG.zip). The Dragonfly_Dragonfly component is supposed to download this file in the background the first time that you drop itnon the canvas but something might have been stopping this from happening on your machine. I should write an error/warning message if this download fails.

I’m also happy to hear that you plan to use the UWG to inform your thesis. The most comprehensive documentation. That exists right now is in Bruno’s PhD thesis (Bruno being the original developer):

There’s also some documentation on the urban microclimate group website:

I know that many of the original UWG functions come from a Linux program called Town Energy Budget (TEB).

The FatalError messages that you are getting in the command prompt are likely the result of a bug in the UWG. I had discovered several when I first started working with it, particularly if you specify really thin materials on the constructions. If you post an issue to the UGW github with a link to the XML file generated by Dragonfly, I imagine Joseph should fix the bug soon:


Firstly thanks for your precious suggestions!

Secondly I have the same issue and I didn’t change anything before last run, so with a video capture app I was able to grap a flash command prompt window. It displays: “.\UWGEngine” It is not recognized as an internal or external command, operable program or batch file.

(Anyway I will post an issue to the UWG github about the othe issue with "Fatal Error Message).


I am facing some errors when I try to run the example file. Can you please let me know where the problem might be. Is there any component that I have not installed?