Dragonfly / UWG doesn't run


#1

Hi everyone,

Since the example file from Hydra didn’t work, probably because some of the components are outdated, I tried to set up a very basic document with my own geometry using the newer components. However, some errors occur.

Some geometries, pluged into the BuildingTypologies component lead to this error:

  1. Solution exception:iteration over non-sequence of type NoneType

Even if no error messages are displayed, the Run UWG component simply doesn’t run. I tried to use the older version of this component, which tells me that the UWG city input is not valid. But the newest component doesnt complain, but doesn’t run either.

I appreciate every hint that helps me to solve this issue. Am I missing something very basic?

Thanks!

Best, Kai

UWG second try.gh (1.9 MB)


#2

@kai.liebetanz

You’re using the new components from the Dragonfly github repo correct? It’s not working because they’re still a work in progress. If you can wait two or three weeks (tentative estimate) then they should be ready for release then. If not, then we will have to try and debug your set up with the older version.


#3

Ok, I didn’t know that. For now, it works fine with the old ones. Thanks!


#4

@kai.liebetanz ,

The version on Hydra is a working one, which you can use until we get some install instructions up for the new Dragonfly.

I think the reason why the hydra example might not be running for you is that your geometry is very complex. For your case here, we’re going to have a workflow in the new Dragonfly for generating building typologies from footprint polygons and an average number of stories, which will make your case here much more manageable.


#5

@chris,
How can I find version on hydra? I see that the latest user objects have errors since they are WIP but I am looking for UWG 0.0.1 Which used to work just fine. Where can I get those user objects?


#6

@devang ,

Actually, as of last night, the new components on the Dragonfly github are good enough for general use so I am going to start recommending that people shift to those. At this point, I just have to add a Dragonfly update component and update the Hydra examples and then I can announce it more officially. But you should feel free to try it out yourself by following the install instructions here:


… and you can start getting familiar with the new workflows by browsing these example files: