Energy Plus simulation error on Honeybee:'ascii' can't encode character '/u131 in position 156

Hi ,

I was triying the tutorials series about honeybee and ladybug while doing it I had an error like this could u please help me?

Hi Erol,

Can you share your file? I could take a look.


do you mean the gh or the energyplus file in C:/?

EnergyPlus doesn’t like special characters. I remember someone had a similar issue for weather file for Izmir. Are you using Izmir’s weather file? Can you share the file with me so we can see if there is an easy way to get this fixed.

oh sorry didn’t see your reply and I asked the same question ,yeah I am using the Izmir weather file which file should I share?

I tried to use some other weather files like ankara and new york-albany but it didnt work either

Hi Erol,

Can you share your Grasshopper file with weather file?


. (496 KB) (236 KB)

Hi Erol,

Please find attached file. It works now.

-Devang (496 KB)

still having the same problem

This is strange. It runs fine on my machine. Will try to find a fix.

Can you copy/paste the whole path where the weather file is located.

Can be that there are special characters?


yeah the problem with the asci was that the turkish word for desktop “masaüstü” is and it dont get the letter ü I think I change the place of the weather file and it worked but now I get this problem

I wonder why your are not using the file Devang uploaded for you. I tried it and it works just fine.

From the image you attached i see that you are using a very old HB version (2015).


devangs file is still giving the same error

Hi Erol,

Where exactly did you locate this turkish word? Was that in the EPW file?


No it was not in the EPW file it was on the path of EPW file

I believe that explains why the error is not appearing on my or Abraham’s machine. This looks more like a local issue.

Try giving a path in the workingDir_ input of the LB_EPW+STAT. I suspect the component is downloading the weather files to a location in your machine with the ucode issues.