EnergyPlus error - Non-convex surfaces

Hi all,

I am trying to build a residencial building, but when I ran E+ is given me a message:

  1. The simulation has not run correctly because of this severe error:
    ** Severe ** DetermineShadowingCombinations: There are 2 surfaces which are casting surfaces and are non-convex

Could anyone help me to solve that problem? how can I find those surfaces

Any suggestions? The gh file is attached.

Thank you,

Libner (573.2 KB)

Hello @libner.melo, It appears that you’re missing an avatar! Please set it up in your profile! Thanks. :slight_smile:

Hi @libner.melo,

  1. All the materials defined by you are not being successfully written to E+. Please correct that
  2. Please see non-convex surface in your model (580.1 KB)
  3. You may please also refer this and that

Hope this helps!


Hi Devang,

thanks, thats is super helpful.
But I’m getting a problem on how can I split these non-convex surfaces to run E+ correctly… I’ve been trying so many different things but it didn’t work

I split the surfaces of the zone that was an giviing error. Please find the revised file (589.9 KB)
One another way to avoid such errors is to use Honeybee_Energy Simulation Parameter component and use minimal shadowing[0] or fulllexterior[1] from the solarDistribution input.

1 Like

Is there another way to solve non-convex surface without having to bake and split it on rhino?
I would like to creat my geometris just on grasshopper and during the tests be able to modifie those geometris and at the same time solve non-convex surfaces

As @devang said, set the HB_Energy Simulation Parameter, solarDistribution input to lower resolution.

In this case and not in general, if you want to fix the geometries inside the grasshopper, you can use split surface (Surface Split)and provide intersection curves. (598.6 KB)


1 Like

Thank you so much! It really helps me a lot :slight_smile: