EPW to WEA Component Error

I appreciate greatly your support.
I will try first to narrow down the stations I will need the most and leave the others out.

I will let you know!

Best regards,


Hi @Federico587, I checked the file for Yuzawa today and the error was because there were several extra , at the end of each line. I added an extra check to handle cases like this:

I cannot recreate this error. Can you update your installation and use the latest version from GitHub and test the files again. It might be fixed after the recent modification that @devang has made to sunpath.

Hi @mostapha,

thanks very much for having a look at this.

How should I do this? You mean install the last version of HB and LB legacy? Or use the update components on GH canvas?

Another thing: for what I can understand you solved the problem for ladybug (legacy). Do you think it can be done also for HB legacy and HB[+]?

I am gonna check the files as soon as I can and I will get back at you.

Best regards,


Hi @Federico587, The fixes are all for Ladybug[+] and Honeybee[+]. Ladybug legacy doesn’t have a WEA component. By updating the plugins I meant updating Honeybee[+] plugins which can be done manually or by using this component.

I’m wrapping up a new installation package for the [+] plugins. If you can wait until the end of the week then you can download the new version which has multiple bug fixes and improvements.

4 posts were split to a new topic: “Remove_Ladybug_and_Honeybee.gh” file also removes HB[+]!

Hi @mostapha and @devang,

i seem to have a similar issue with this component but not sure it comes from the same reasons.
I tried both with an epw. file on my computer and from url directly

i got this error message : “1. Solution exception:from_epw_file() takes exactly 2 arguments (3 given)”

Any idea about it ?
Related to my HB[+] version maybe ?

It’s OK finally, my version of the component wasn’t the last updated one available