'EPZone' object has no attribute 'cenPt'?

We need to check your file to be able to figure this out. In general, this error happens when center point of the zone is outside the zone. I can see that to be the case for your geometries but again if you upload the geometries we can take a look.


I have the same issue with the ‘EPZone’ object has no attribute ‘cenPt’ error.

I’ve looked through all the forum posts about this, and I’ve checked my file multiple times…

I tried putting the HB_HB back using Ctrl+B

I tried re-enabling it

I restarted my computer several times just in case…

I checked the zone names but they seem to be fine…

Attached are the internalized geometry with the script and an epw file that I used. Hopefully it will work for you so that will mean something with my HB version is wrong, I just don’t want to re-install everything until that is the case.

Thanks :slight_smile:

hi,the problem for me solved when i rebuild my geometry


Yeah I’ve tried that a bunch of times… I tried to attach the files before but the site is buggy at the moment… i’ll try again now.

I played with the geometry for A WHILE until I finally got 6 zones each composed of surfaces that some have windows etc. I separated the surfaces and windows into parents and children and re-joined them into ‘closed brep’ legitimate HBZones.

Nonetheless, the simulation doesn’t run when they are connected and says that the index is out of range.

When I connect only one of the HBZones it works. More than one it doesn’t. Weird.

Again, i’m trying to attach here the script and internalized geometry in hopes that someone can understand this…



There is no attachment! Did you also try to update ladybug and honeybee?



For some reason my browser doesn’t attach it properly. I’ll try again here.

Yes I did update HB and LB but then all the tests after didn’t work. Apparently 1 brep works in the simulation, but the moment I add another one to the HBZones it fails.

The error is : “Solution exception:index out of range: 0”

Hopefully the attachments are correct now. I’m using an online file sharing site.


Should be 2 files there (.gh and .epw)

Hi Yafim

You have not internalized all your geometry so it is not possible to check.



Hi Duncan,

Thanks you’re right I forgot about some of it. My apologies. Here is the link to the updated one. please tell me if it’s ok.



Hi Yafim

Yep geometry is now all there.

So I think the issue is that that you are decomposing your zones to create your glazed surfaces. This is causing a couple of problems.

One of the issues is that the stair zone surfaces adjacent to the 1st, 2nd, 3rd and 4th zone vertical surfaces with windows are failing as the stair surfaces are looking for glazed child surfaces. You can split out your surfaces and then solve adjacencies to overcomes this so that surfaces with windows are not adjacent. You can of course split these out in the geometry beforehand. I’m not sure if this is a recurring problem as I have not noticed it before, perhaps Chris or Mostapha can comment.

I’ve also a feeling that as you have split your zones the zone centre point is being thrown out so if you rebuild the zones afterwards this should overcome the issue.

Apologies as I have updated the file to new HB but I don’t think this was causing the problem.

I’d take notice of the report output as you have a number of warnings coming out of that file.



file here http://dropcanvas.com/6bq0v

also having issues with attaching files

Hi Duncan thanks for the help it’s running the simulation.

I basically did again the solve adjacencies after the glazing surface process, and now it seems okay I think.

However, after running the simulation and trying out the ‘ColorZones’ component, it colors only the floor of each zone and not the entire zone itself.

I checked the zone list and there are 6 items each a zone, not surfaces, so this is strange that it would color only one surface in each zone…


Any ideas?

Thanks again.


Just plug the zone breps to a custom preview geometry and the zone colors to the custom preview shader. (from the color zones component)


Silly me… Thanks Duncan for all the help :slight_smile:

I will enjoy exploring this plugin.