Error importing IDF

I am trying to import an IDF file from Design-Builder. When I tried (idf version 9.40 and 9.50) to import it using the “Load gbXML OSM IDF” component, the following error appears:
" Runtime error (FileNotFoundException): Could not find file ‘C:\Users\Gebruiker\simulation\opus coolingdesign_v940.hbjson’. Traceback: line 116, in script"

Any Thoughts?

Error Importing IDF (8.8 KB)
IDF Files

  • Prethvi

Hey @Prethvi ,

Check the LBT compatibility matrix. You will see that the later versions of Ladybug Tools only work with EnergyPlus 9.6 or 22.1. So you won’t be able to import these older IDFs into the latest Ladybug Tools unless you use the IDFVersionUpdater program to change them to a version of EnergyPlus that’s compatible with what Ladybug Tools is using.

FYI, when I update your IDF to EnergyPlus version 22.1, I have no issues trying to import it with the latest development version the LBT plugin that uses E+ 22.1. Something seems pretty weird about your DesignBuilder geometry, though:

I don’t know about that weird tail that your model has growing out of its bottom.

Hi @chris,
Thank you for the input. I tried updating the IDF file to V960 and uploaded it to the drive.

The following error appears while importing the file:

Traceback (most recent call last):
File “C:\Users\Gebruiker\ladybug_tools\python\Lib\site-packages\honeybee\”, line 344, in apply_properties_from_dict
File “C:\Users\Gebruiker\ladybug_tools\python\Lib\site-packages\honeybee_energy\properties\”, line 597, in apply_properties_from_dict
_, constructions, construction_sets, _, schedules, program_types, hvacs, shws =
File “C:\Users\Gebruiker\ladybug_tools\python\Lib\site-packages\honeybee_energy\properties\”, line 787, in load_properties_from_dict
invalid_dict_error(t_lim, e)
File “C:\Users\Gebruiker\ladybug_tools\python\Lib\site-packages\honeybee\”, line 288, in invalid_dict_error
raise ValueError(’{} “{}” is invalid:\n{}’.format(obj_type, full_id, error))
ValueError: ScheduleTypeLimit “ClothingInsulation” is invalid:
unit_type Clothinginsulation is not recognized.
Choose from the following:
(‘Mode’, ‘Availability’, ‘Control’, ‘Temperature’, ‘Power’, ‘ConvectionCoefficient’, ‘Percent’, ‘PrecipitationRate’, ‘Velocity’, ‘Angle’, ‘DeltaTemperature’, ‘Dimensionless’, ‘ActivityLevel’, ‘Capacity’)
Runtime error (PythonException): Failed to apply energy properties to the Model: ScheduleTypeLimit “ClothingInsulation” is invalid:
unit_type Clothinginsulation is not recognized.
Choose from the following:
(‘Mode’, ‘Availability’, ‘Control’, ‘Temperature’, ‘Power’, ‘ConvectionCoefficient’, ‘Percent’, ‘PrecipitationRate’, ‘Velocity’, ‘Angle’, ‘DeltaTemperature’, ‘Dimensionless’, ‘ActivityLevel’, ‘Capacity’)

line 348, in apply_properties_from_dict, “C:\Users\Gebruiker\ladybug_tools\python\Lib\site-packages\honeybee\”
line 204, in from_dict, “C:\Users\Gebruiker\ladybug_tools\python\Lib\site-packages\honeybee\”
line 120, in script

Hey @Prethvi ,

This is an issue that is fixed in the latest development version of the LBT plugin. If you run the “LB Versioner”, install OpenStudio 3.4 (with EnergyPlus 22.1), and update your IDF to version 22.1, then you should be able to import your IDF without issues.


Hey Chris,

I’m having the same issue as Prethvi despite updating to the latest ladybug version (1.1.4) and OpenStudio 3.4 as well as EnergyPlus 22.1. I’ve also updated my IDF file to Energyplus version 22.1 using IDF Version Updater.

Am I missing anything here?

1 Like

@mschoenfeld ,

It sounds like your issue may be different and I suggest opening a new topic and uploading a file to recreate the issue.

Hai, Has this problem been created a new topic? I have implemented what crish has instructed, but I have also experienced it. I have followed the directions of the LBT compatible matrix according to version 1.5 and have installed Energy plus 22.1. But the same problem has been experienced. What is the solution?

I have an error 1. Solution exception:Could not find file ‘C:\Users\adenu\simulation\airflownetwork_multizone_house.hbjson’.

@adenurmap ,

LBT 1.4 is fairly old at this point given that we just released LBT 1.8 last week. Have you tried seeing if you can import it with the newer version of the plugin?

My guess is that, even if the import still fails in LBT 1.8, it will give you a much clearer failure message that tells you the version that you’d have to update your IDF to in order to make it import successfully.

Thank u @Chris Thanks Chris I will try it

1 Like