Error in Accelerad-Honeybee simulation

Hi all!

I was testing the Accelerad method for daylight simulations with Honeybee but, unfortunately, I ran into an error message. Despite the warning, the simulation creates an HDRI image as an output in the working direction, which I can successfully open in Honeybee. I would like to note that the script was working without any problem in Radiance.

Apart from this, when I tried to increase the quality of the RadParameters from 0 to 1 or 2 the error message changed indicating an unexpecting error with CUDA according to the exception. Even when I decreased the CPU from 4 to 1 the problem was still the same, but when I increased only the bounces with the total quality being set to 0, then the error changed back to the initial one without any reference to CUDA problems.

Please find attached the initial error.log, the HDRI images and the new error.log.

Thank you in advance.


initial_error.log (3.8 KB)

new_error.log (4.2 KB)

Hi @tsianaka.efi , I’m very interested in testing the Accelerad engine as well. So far its been a bit crafty on my side, could you share how you are managing the different radiance versions, rcontrib and rtrace within grasshopper.

I think that the default sets of radParameters are not meant to configure Accelerad optimally.

Hi @tsianaka.efi,

Thank you for reporting this. We can modify the processing of the log to change to a warning rather than an error so in this case it doesn’t fail.

For the CUDA error Nathaniel can get it fixed inside Accelerad. I’m copying a link to the conversation in mailing list here for reference:

1 Like

Hi all,

Thank you very much for your responses! :slight_smile:
I just saw that Nathaniel also suggested a possible solution about this error in the conversation’s link that @mostapha shared, but I have not tested it yet.
@OlivierDambron you can directly copy+replace them from Accelerad to the Radiance folder as noted by Nathaniel or you can change the path for the Radiance files to another by modifying the dictionary (hb_folders = sc.sticky[“honeybee_folders”]). Personally, I check those two methods in two laptops and compare the findings. I am not sure but hope I helped.


@tsianaka.efi, Let us know if the -w option solves the issue otherwise we can modify the parsing of error logs.

I have followed

[quote=“mostapha, post:3, topic:2534”]
[/quote] to add -t 1.5.

But Honeybee also showed some error and failed to read the results.

So I think Honeybee is not very compatible for Accelerad.

@mostapha Could you check the Honeybee runDaylightAnalysis component if you are available ?

After i tried many version of Accelerad, I discovered the 05_beta can work fine with Honeybee, but 05_beta ran with some error with image-based simulation. It means that Honeybee with Accelerad can run fine,but can not read the HDR files. We need to read HDR files using Honeybee_imageviewer manually.

Are you using the latest version of honeybee? I thought we already change the error message to a warning so you still get the results.